dev-util/pscan: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Wed, 21 Aug 2019 07:55:05 +0000 (09:55 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 21 Aug 2019 07:55:05 +0000 (09:55 +0200)
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
dev-util/pscan/Manifest
dev-util/pscan/files/pscan-20000721-fix-build-system.patch [new file with mode: 0644]
dev-util/pscan/pscan-20000721-r1.ebuild

index 3b1dc0e4df0c38fb96f84839fed303e2d8207818..8acbd564f9984db57903d45be687d4c772e541e1 100644 (file)
@@ -1 +1 @@
-DIST pscan.tar.gz 14555 BLAKE2B 8e1a8ea91bc2a1b323dc607f703565579e596a3001151609e46a09160766b3b913610a15b64859dc88031a3acf2e3c147dcbd7b033517d3786976ab3cb1bc9f4 SHA512 83196cc9c450217fc2287d38fd1a0b9d1d9951b8f6328b6b9f7f50b680f653b099af04d4c448f3cb2b2a96871eec8772557851e887faa2f41dc259f01c031e78
+DIST pscan-20000721.tar.gz 14555 BLAKE2B 8e1a8ea91bc2a1b323dc607f703565579e596a3001151609e46a09160766b3b913610a15b64859dc88031a3acf2e3c147dcbd7b033517d3786976ab3cb1bc9f4 SHA512 83196cc9c450217fc2287d38fd1a0b9d1d9951b8f6328b6b9f7f50b680f653b099af04d4c448f3cb2b2a96871eec8772557851e887faa2f41dc259f01c031e78
diff --git a/dev-util/pscan/files/pscan-20000721-fix-build-system.patch b/dev-util/pscan/files/pscan-20000721-fix-build-system.patch
new file mode 100644 (file)
index 0000000..cd22fc2
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,16 +13,10 @@
+ #CC=gcc -Wall -g
+ #LEX=flex
+-pscan: scanner.yy.o pscan.o
+-      $(CC) scanner.yy.o pscan.o -o pscan
+-
+-scanner.yy.o: scanner.yy.c
+-      $(CC) -c scanner.yy.c -o scanner.yy.o
++pscan: scanner.yy.o
+ scanner.yy.c: scanner.l
+       $(LEX) -t scanner.l > scanner.yy.c
+-pscan.o: pscan.c pscan.h
+-
+ clean:
+       rm -f *.o *~ pscan scanner.yy.c core
index 11c078d3650bba89d18d4a0f0ed381c28591e5ad..e63242af2bded0948ad3d268a75366a76440433e 100644 (file)
@@ -1,34 +1,31 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit toolchain-funcs
 
 DESCRIPTION="A limited problem scanner for C source files"
 HOMEPAGE="http://www.striker.ottawa.on.ca/~aland/pscan/"
-# I wish upstream would version their files, even if it's only with a date
-SRC_URI="http://www.striker.ottawa.on.ca/~aland/pscan/pscan.tar.gz"
+SRC_URI="mirror://gentoo/pscan.tar.gz -> ${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
 IUSE=""
-
 # Does NOT contain a testsuite, but does contain a test.c that confuses src_test
 RESTRICT="test"
 
-RDEPEND=""
-DEPEND="${RDEPEND}
-       sys-devel/flex"
+BDEPEND="sys-devel/flex"
 
 S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
 
-src_compile() {
-       emake CC="$(tc-getCC) ${CFLAGS}" || die
+src_configure() {
+       tc-export CC
 }
 
 src_install() {
-       newbin pscan printf-scan || die
-       dodoc README find_formats.sh test.c wu-ftpd.pscan || die
+       newbin pscan printf-scan
+       dodoc README find_formats.sh test.c wu-ftpd.pscan
 }