net-libs/farstream: add missing gst-plugins-srtp runtime dep
authorMart Raudsepp <leio@gentoo.org>
Wed, 22 Aug 2018 19:03:06 +0000 (22:03 +0300)
committerMart Raudsepp <leio@gentoo.org>
Wed, 22 Aug 2018 19:20:00 +0000 (22:20 +0300)
Closes: https://bugs.gentoo.org/664174
Package-Manager: Portage-2.3.48, Repoman-2.3.10

net-libs/farstream/farstream-0.2.8-r2.ebuild [new file with mode: 0644]

diff --git a/net-libs/farstream/farstream-0.2.8-r2.ebuild b/net-libs/farstream/farstream-0.2.8-r2.ebuild
new file mode 100644 (file)
index 0000000..e199f1c
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="Audio/video conferencing framework specifically designed for instant messengers"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/Farstream"
+SRC_URI="https://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+introspection test upnp"
+SLOT="0.2/5" # .so version
+
+# Tests need shmsink from gst-plugins-bad, which isn't packaged
+# FIXME: do an out-of-tree build for tests if USE=-msn
+RESTRICT="test"
+
+COMMONDEPEND="
+       >=media-libs/gstreamer-1.4:1.0
+       >=media-libs/gst-plugins-base-1.4:1.0
+       >=dev-libs/glib-2.32:2
+       >=net-libs/libnice-0.1.8
+       introspection? ( >=dev-libs/gobject-introspection-0.10.11:= )
+       upnp? ( >=net-libs/gupnp-igd-0.2:= )
+"
+RDEPEND="${COMMONDEPEND}
+       >=media-libs/gst-plugins-bad-1.4:1.0
+       >=media-libs/gst-plugins-good-1.4:1.0
+       media-plugins/gst-plugins-srtp:1.0
+       media-plugins/gst-plugins-libnice:1.0
+"
+DEPEND="${COMMONDEPEND}
+       ${PYTHON_DEPS}
+       >=dev-util/gtk-doc-am-1.18
+       virtual/pkgconfig
+       test? (
+               media-libs/gst-plugins-base:1.0[vorbis]
+               media-libs/gst-plugins-good:1.0 )
+"
+
+pkg_setup() {
+       python-any-r1_pkg_setup
+}
+
+src_configure() {
+       plugins="fsrawconference,fsrtpconference,fsmsnconference,fsrtpxdata,fsfunnel,fsrtcpfilter,fsvideoanyrate"
+       gnome2_src_configure \
+               --disable-static \
+               $(use_enable introspection) \
+               $(use_enable upnp gupnp) \
+               --with-plugins=${plugins}
+}
+
+src_compile() {
+       # Prevent sandbox violations, bug #539224
+       # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+       # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+       addpredict /dev
+       gnome2_src_compile
+}