app-shells/bash-completion: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 09:29:05 +0000 (11:29 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 09:36:45 +0000 (11:36 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-shells/bash-completion/Manifest
app-shells/bash-completion/bash-completion-2.9-r1.ebuild [deleted file]

index cb45623e7ccd942d3c82c65623a9a0733e0164f7..3620b452cc2743f7d9570b6b001fa7ed2d85e87e 100644 (file)
@@ -1,3 +1,2 @@
 DIST bash-completion-2.10.tar.xz 310764 BLAKE2B b6b96f049b44eb455805916bbbeb0c9578104aa4c8c736801fd27c7268e4de70424eebbb5d1e4d1841273b1c4e169da4f369f2f65276349ead4aa7944aa193b2 SHA512 d434e0e48b25328e8c6b43ed64e58f56459186434754ee972795edd031ce1864038b53926b218fe06e5b3882682db4dec5101b3124362c0137101d3fa6d87cd7
-DIST bash-completion-2.9.tar.xz 305788 BLAKE2B c8a05bbb16fb671d73025c2fc579f77569251974a57fa4125a8e0aebcbed4e50fc1a47b9743abab0264599ffdef30b33cb540c6c3ab0d8a3577c6dda95f622b6 SHA512 e864091196d670699bdb2af3fc40464788e79c932fa564afa7ba34a637aa1583db7dbceab0e7ba6718fac99e9fd2dfb03d1ee51d7cf279d925ad63f60401d7d5
 DIST bashcomp-2.0.3.tar.gz 3539 BLAKE2B 75304d144792cc7f6ad5455a05a65c33c646d6f7384d020a06a1fcf012cd51625a3dd0750ad539253453b1eede196c340286a1e81737f0835b5091609ba01295 SHA512 b2bd185ccbd4456939ccc731cc1983fcec2b9564a9920642a753fadd5d897fdb96b925ac1524657629d621d45b37d99076c8ae72511a827e96ff6c388d720008
diff --git a/app-shells/bash-completion/bash-completion-2.9-r1.ebuild b/app-shells/bash-completion/bash-completion-2.9-r1.ebuild
deleted file mode 100644 (file)
index c7c3054..0000000
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-BASHCOMP_P=bashcomp-2.0.3
-PYTHON_COMPAT=( python3_{6,7} )
-inherit bash-completion-r1 python-any-r1
-
-DESCRIPTION="Programmable Completion for bash"
-HOMEPAGE="https://github.com/scop/bash-completion"
-SRC_URI="
-       https://github.com/scop/bash-completion/releases/download/${PV}/${P}.tar.xz
-       eselect? ( https://github.com/mgorny/bashcomp2/releases/download/v${BASHCOMP_P#*-}/${BASHCOMP_P}.tar.gz )"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
-IUSE="+eselect test"
-RESTRICT="test"
-
-# completion collision with net-fs/mc
-RDEPEND=">=app-shells/bash-4.3_p30-r1:0
-       sys-apps/miscfiles
-       !!net-fs/mc"
-DEPEND="app-arch/xz-utils
-       test? (
-               ${RDEPEND}
-               app-misc/dtach
-               dev-util/dejagnu
-               dev-tcltk/tcllib
-               $(python_gen_any_dep '
-                       dev-python/pexpect[${PYTHON_USEDEP}]
-                       dev-python/pytest[${PYTHON_USEDEP}]
-               ')
-       )"
-PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
-
-strip_completions() {
-       # Remove unwanted completions.
-       local strip_completions=(
-               # Slackware package stuff, quite generic names cause collisions
-               # (e.g. with sys-apps/pacman)
-               explodepkg installpkg makepkg pkgtool removepkg upgradepkg
-
-               # Debian/Red Hat network stuff
-               ifdown ifup ifquery ifstatus
-
-               # Installed in app-editors/vim-core
-               xxd
-
-               # Now-dead symlinks to deprecated completions
-               hd ncal
-       )
-       if [[ ${ARCH} != *-fbsd && ${ARCH} != *-freebsd ]]; then
-               strip_completions+=(
-                       freebsd-update kldload kldunload portinstall portsnap
-                       pkg_deinstall pkg_delete pkg_info
-               )
-       fi
-
-       local file
-       for file in "${strip_completions[@]}"; do
-               rm "${ED}"/usr/share/bash-completion/completions/${file} ||
-                       die "stripping ${file} failed"
-       done
-
-       # remove deprecated completions (moved to other packages)
-       rm "${ED}"/usr/share/bash-completion/completions/_* || die
-}
-
-pkg_setup() {
-       use test && python-any-r1_pkg_setup
-}
-
-python_check_deps() {
-       has_version "dev-python/pexpect[${PYTHON_USEDEP}]" &&
-       has_version "dev-python/pytest[${PYTHON_USEDEP}]"
-}
-
-src_prepare() {
-       use eselect &&
-               eapply "${WORKDIR}/${BASHCOMP_P}/bash-completion-blacklist-support.patch"
-       # Bug 543100, update bug 601194
-       eapply "${FILESDIR}/${PN}-2.1-escape-characters-r1.patch"
-       eapply_user
-}
-
-src_test() {
-       # Tests need an interactive shell, #477066
-       # idea stolen from:
-       # http://pkgs.fedoraproject.org/cgit/rpms/bash-completion.git/tree/bash-completion.spec
-
-       # real-time output of the log ;-)
-       touch "${T}/dtach-test.log" || die
-       tail -f "${T}/dtach-test.log" &
-       local tail_pid=${!}
-
-       # override the default expect timeout and buffer size to avoid tests
-       # failing randomly due to cold cache, busy system or just more output
-       # than upstream anticipated (they run tests on pristine docker
-       # installs of binary distros)
-       nonfatal dtach -N "${T}/dtach.sock" \
-               bash -c 'emake check RUNTESTFLAGS="OPT_TIMEOUT=300 OPT_BUFFER_SIZE=1000000" PYTESTFLAGS="-vv" \
-                       &> "${T}"/dtach-test.log; echo ${?} > "${T}"/dtach-test.out'
-
-       kill "${tail_pid}"
-       [[ -f ${T}/dtach-test.out ]] || die "Unable to run tests"
-       [[ $(<"${T}"/dtach-test.out) == 0 ]] || die "Tests failed"
-}
-
-src_install() {
-       # work-around race conditions, bug #526996
-       mkdir -p "${ED}"/usr/share/bash-completion/{completions,helpers} || die
-
-       emake DESTDIR="${D}" profiledir="${EPREFIX}"/etc/bash/bashrc.d install
-
-       strip_completions
-       # fix missing aliases
-       bashcomp_alias tar bsdtar gtar star
-
-       dodoc AUTHORS CHANGES CONTRIBUTING.md README.md
-
-       # install the eselect module
-       if use eselect; then
-               insinto /usr/share/eselect/modules
-               doins "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect"
-               doman "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect.5"
-       fi
-}
-
-pkg_postinst() {
-       local v
-       for v in ${REPLACING_VERSIONS}; do
-               if ver_test "${v}" -lt 2.1-r90; then
-                       ewarn "For bash-completion autoloader to work, all completions need to"
-                       ewarn "be installed in /usr/share/bash-completion/completions. You may"
-                       ewarn "need to rebuild packages that installed completions in the old"
-                       ewarn "location. You can do this using:"
-                       ewarn
-                       ewarn "$ find ${EPREFIX}/usr/share/bash-completion -maxdepth 1 -type f '!' -name 'bash_completion' -exec emerge -1v {} +"
-                       ewarn
-                       ewarn "After the rebuild, you should remove the old setup symlinks:"
-                       ewarn
-                       ewarn "$ find ${EPREFIX}/etc/bash_completion.d -type l -delete"
-               fi
-       done
-
-       if has_version 'app-shells/zsh'; then
-               elog
-               elog "If you are interested in using the provided bash completion functions with"
-               elog "zsh, valuable tips on the effective use of bashcompinit are available:"
-               elog "  http://www.zsh.org/mla/workers/2003/msg00046.html"
-               elog
-       fi
-}