net-im/bitlbee: sync 3.6 with live ebuild
authorPetr Vaněk <arkamar@atlas.cz>
Fri, 1 May 2020 09:49:03 +0000 (11:49 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 5 May 2020 08:46:35 +0000 (11:46 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Petr Vaněk <arkamar@atlas.cz>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-im/bitlbee/bitlbee-3.6-r1.ebuild [moved from net-im/bitlbee/bitlbee-3.6.ebuild with 94% similarity]

similarity index 94%
rename from net-im/bitlbee/bitlbee-3.6.ebuild
rename to net-im/bitlbee/bitlbee-3.6-r1.ebuild
index 3fba9718c97b4a8025d44469c8c39ce8ae54a1e6..847614625a9255f1798c1b3921e78c80fdf18470 100644 (file)
@@ -3,7 +3,9 @@
 
 EAPI=7
 
-inherit systemd toolchain-funcs
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit python-any-r1 systemd toolchain-funcs
 
 if [[ ${PV} == "9999" ]]; then
        EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
@@ -32,7 +34,7 @@ REQUIRED_USE="
 COMMON_DEPEND="
        acct-group/bitlbee
        acct-user/bitlbee
-       >=dev-libs/glib-2.16
+       dev-libs/glib:2
        purple? ( net-im/pidgin )
        libevent? ( dev-libs/libevent:= )
        otr? ( >=net-libs/libotr-4 )
@@ -46,12 +48,17 @@ COMMON_DEPEND="
        )
 "
 DEPEND="${COMMON_DEPEND}
-       virtual/pkgconfig
        selinux? ( sec-policy/selinux-bitlbee )
-       test? ( dev-libs/check )"
+       test? ( dev-libs/check )
+"
 
 RDEPEND="${COMMON_DEPEND}
-       xinetd? ( sys-apps/xinetd )"
+       xinetd? ( sys-apps/xinetd )
+"
+
+BDEPEND="${PYTHON_DEPS}
+       virtual/pkgconfig
+"
 
 PATCHES=(
        "${FILESDIR}"/${PN}-3.5-systemd-user.patch