games-util/lgogdownloader: Patch 3.5 to fix build with newer jsoncpp
authorJames Le Cuirot <chewi@gentoo.org>
Wed, 20 Nov 2019 22:33:22 +0000 (22:33 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Wed, 20 Nov 2019 22:33:22 +0000 (22:33 +0000)
Patch has been sent upstream.

Closes: https://bugs.gentoo.org/700452
Package-Manager: Portage-2.3.79, Repoman-2.3.17
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-util/lgogdownloader/files/jsoncpp.patch [new file with mode: 0644]
games-util/lgogdownloader/lgogdownloader-3.5.ebuild

diff --git a/games-util/lgogdownloader/files/jsoncpp.patch b/games-util/lgogdownloader/files/jsoncpp.patch
new file mode 100644 (file)
index 0000000..d865903
--- /dev/null
@@ -0,0 +1,27 @@
+From ff353126ecda61824cf866d3807c9ebada96282e Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Wed, 20 Nov 2019 22:24:10 +0000
+Subject: [PATCH] Fix find_path for newer jsoncpp release
+
+features.h was renamed but allocator.h wasn't so the latter works with
+both old and new versions.
+---
+ cmake/FindJsoncpp.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/FindJsoncpp.cmake b/cmake/FindJsoncpp.cmake
+index 5731980..0c8e0fb 100644
+--- a/cmake/FindJsoncpp.cmake
++++ b/cmake/FindJsoncpp.cmake
+@@ -10,7 +10,7 @@ pkg_check_modules(PC_JSONCPP REQUIRED jsoncpp)
+ find_path(JSONCPP_INCLUDE_DIR
+   NAMES
+-    json/features.h
++    json/allocator.h
+   HINTS
+     ${PC_JSONCPP_INCLUDEDIR}
+     ${PC_JSONCPP_INCLUDEDIRS}
+-- 
+2.23.0
+
index 0f8ac4e4d85d62efd1b44b52c63fdc27c5bdde13..9a73f51a45c842f4504b879bb11e5888f69d101b 100644 (file)
@@ -27,6 +27,10 @@ DEPEND="${RDEPEND}"
 BDEPEND="sys-apps/help2man
        virtual/pkgconfig"
 
+PATCHES=(
+       "${FILESDIR}"/jsoncpp.patch
+)
+
 src_configure() {
        local mycmakeargs=(
                -DUSE_QT_GUI=$(usex gui)