Bug #213629 - Use EAPI.incompatible in cases where EAPI=0 and a default
authorZac Medico <zmedico@gentoo.org>
Fri, 28 Mar 2008 13:07:05 +0000 (13:07 -0000)
committerZac Medico <zmedico@gentoo.org>
Fri, 28 Mar 2008 13:07:05 +0000 (13:07 -0000)
IUSE is encountered.

svn path=/main/branches/2.1.2/; revision=9577

bin/repoman

index cc558d6915fb6de776d9d51b48eef6713d8dc1f6..38de132edba681deafb95f6ed9f2cbf5bb107321 100755 (executable)
@@ -1679,8 +1679,15 @@ for x in scanlist:
                        for mypos in range(len(myuse)-1,-1,-1):
                                if myuse[mypos] and (myuse[mypos] in luselist[mykey]):
                                        del myuse[mypos]
-               if default_use and myaux["EAPI"] == "0":
-                       myuse += default_use
+
+               if default_use and eapi == "0":
+                       for myflag in default_use:
+                               stats['EAPI.incompatible'] += 1
+                               fails['EAPI.incompatible'].append(
+                                       (relative_path + ": IUSE defaults" + \
+                                       " not supported with EAPI='%s':" + \
+                                       " '%s'") % (eapi, myflag))
+
                for mypos in range(len(myuse)):
                        stats["IUSE.invalid"]=stats["IUSE.invalid"]+1
                        fails["IUSE.invalid"].append(x+"/"+y+".ebuild: %s" % myuse[mypos])