dev-db/mongodb: version bump, fix #693282
authorAlexys Jacob <ultrabug@gentoo.org>
Sun, 22 Sep 2019 18:57:33 +0000 (20:57 +0200)
committerAlexys Jacob <ultrabug@gentoo.org>
Sun, 22 Sep 2019 18:58:46 +0000 (20:58 +0200)
Package-Manager: Portage-2.3.75, Repoman-2.3.17
Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
dev-db/mongodb/Manifest
dev-db/mongodb/files/mongodb-4.2.0-fix-scons-third-party.patch [new file with mode: 0644]
dev-db/mongodb/files/mongodb-4.2.0-fix-scons.patch [new file with mode: 0644]
dev-db/mongodb/mongodb-4.2.0.ebuild [new file with mode: 0644]

index a80964813a5f16dc0adf71039b5630fc804d4ec2..e468012ed5c454176be3a89d5f75352a397d1650 100644 (file)
@@ -2,3 +2,4 @@ DIST mongodb-src-r3.6.13.tar.gz 40853787 BLAKE2B de9621de4f570d569df5cfe026ea5da
 DIST mongodb-src-r3.6.8.tar.gz 40428295 BLAKE2B cc02f73cfb49fb38ccabaad5a02610ce73fc41895ce944e48669e254bcbc70c8872a1bd7f8e04371fae4fcd9af2466fd8550367dd1d1da5cee50b86fc5023bf2 SHA512 c981f3269be3bafb59aa89d36c39a801fd7007b60db6c09b4616a559aaf8e50b34cabbdac2b59f23552c0a5112913fba468f7e2ed9a5f4daa3702dcffdf34999
 DIST mongodb-src-r4.0.10.tar.gz 49870574 BLAKE2B 1babbfa1a6d8fae390ec37042feff896c402772e832cc5b0b82fc4d531a6487ac2bd8d407c37ca75a76d78bc91cc665bfc3b7b223e6ceaaea2d921b337ef4d19 SHA512 891bfdc0d415515d7aa36aeb0618055ac6815c7d704537b88293226cecc1b677134db621fd90dee3913f4ff8174a888bcf68adee0a243d0f55ef6c0033a4f4b9
 DIST mongodb-src-r4.0.12.tar.gz 49937644 BLAKE2B 81044a6d68be6420d30fb2d7386ff29871a696cad94ce5977c1aba60c2ce80e18ccb86492c1947a359ef124332ea82ac3cb0fb73a68f51904a008fdf911aa055 SHA512 802eaf57d56c5e8e217344f10104a201acb6f5abef0065fc1bb8e6ceef13fe489b7ae46ed0d55b5bad50fe3579860b1c1471d224b51b0f15f968278cb5f6a47a
+DIST mongodb-src-r4.2.0.tar.gz 60781115 BLAKE2B 75531f69647c84f71127d4cdccf13bc21e50586240c767b4c1aa1efbf56cf008bf4f32b3a2011120ad9099da0f97be934375b8dd3d012670034327175c454f0e SHA512 be2f4e00364ac49b1a0490fa859640680a4d10d861252d200bd3db535c770a3b97cee9de6d2b0b6b3622502d055ba92b6c1d88cb1134d251aa2cf50a8951b64c
diff --git a/dev-db/mongodb/files/mongodb-4.2.0-fix-scons-third-party.patch b/dev-db/mongodb/files/mongodb-4.2.0-fix-scons-third-party.patch
new file mode 100644 (file)
index 0000000..6afa0d7
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/third_party/SConscript       2019-09-22 14:31:48.847382840 +0200
++++ b/src/third_party/SConscript       2019-09-22 14:32:56.858997243 +0200
+@@ -188,7 +188,7 @@
+     libraries = thisEnv.Flatten([libraries])
+     parts = thisEnv.Flatten([parts])
+     for lib in libraries:
+-        mods = thirdPartyEnvironmentModifications[lib]
++        mods = thirdPartyEnvironmentModifications.get(lib, {})
+         if not parts:
+             thisEnv.PrependUnique(**mods)
+         else:
diff --git a/dev-db/mongodb/files/mongodb-4.2.0-fix-scons.patch b/dev-db/mongodb/files/mongodb-4.2.0-fix-scons.patch
new file mode 100644 (file)
index 0000000..3c929df
--- /dev/null
@@ -0,0 +1,30 @@
+--- a/SConstruct       2019-08-21 09:25:00.980260318 +0200
++++ b/SConstruct       2019-08-21 09:27:53.653601283 +0200
+@@ -1858,7 +1858,6 @@
+     # -Winvalid-pch Warn if a precompiled header (see Precompiled Headers) is found in the search path but can't be used.
+     env.Append( CCFLAGS=["-fno-omit-frame-pointer",
+                          "-fno-strict-aliasing",
+-                         "-ggdb" if not env.TargetOSIs('emscripten') else "-g",
+                          "-pthread",
+                          "-Wall",
+                          "-Wsign-compare",
+@@ -1870,6 +1869,8 @@
+             env.Append( CCFLAGS=["-Werror"] )
+     env.Append( CXXFLAGS=["-Woverloaded-virtual"] )
++    env.Append( CXXFLAGS=os.environ['CXXFLAGS'] )
++    env.Append( LINKFLAGS=os.environ['LDFLAGS'] )
+     if env.ToolchainIs('clang'):
+         env.Append( CXXFLAGS=['-Werror=unused-result'] )
+@@ -1890,8 +1891,8 @@
+     env.Append( LIBS=[] )
+-    #make scons colorgcc friendly
+-    for key in ('HOME', 'TERM'):
++    #make scons colorgcc, distcc, ccache friendly
++    for key in ('HOME', 'PATH', 'TERM'):
+         try:
+             env['ENV'][key] = os.environ[key]
+         except KeyError:
diff --git a/dev-db/mongodb/mongodb-4.2.0.ebuild b/dev-db/mongodb/mongodb-4.2.0.ebuild
new file mode 100644 (file)
index 0000000..932ef4e
--- /dev/null
@@ -0,0 +1,168 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+SCONS_MIN_VERSION="2.5.0"
+CHECKREQS_DISK_BUILD="2400M"
+CHECKREQS_DISK_USR="512M"
+CHECKREQS_MEMORY="1024M"
+
+inherit check-reqs flag-o-matic multiprocessing pax-utils python-any-r1 scons-utils systemd toolchain-funcs user
+
+MY_P=${PN}-src-r${PV/_rc/-rc}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://fastdl.mongodb.org/src/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0 SSPL-1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug kerberos libressl lto mms-agent ssl test +tools"
+
+RDEPEND=">=app-arch/snappy-1.1.3
+       >=dev-cpp/yaml-cpp-0.6.2:=
+       >=dev-libs/boost-1.70:=[threads(+)]
+       >=dev-libs/libpcre-8.42[cxx]
+       app-arch/zstd
+       dev-libs/snowball-stemmer
+       net-libs/libpcap
+       >=sys-libs/zlib-1.2.11:=
+       kerberos? ( dev-libs/cyrus-sasl[kerberos] )
+       mms-agent? ( app-admin/mms-agent )
+       ssl? (
+               !libressl? ( >=dev-libs/openssl-1.0.1g:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       $(python_gen_any_dep '
+               dev-python/cheetah3[${PYTHON_USEDEP}]
+               dev-python/pyyaml[${PYTHON_USEDEP}]
+               virtual/python-typing[${PYTHON_USEDEP}]
+       ')
+       sys-libs/ncurses:0=
+       sys-libs/readline:0=
+       debug? ( dev-util/valgrind )
+       test? (
+               $(python_gen_any_dep 'dev-python/pymongo[${PYTHON_USEDEP}]')
+       )"
+PDEPEND="tools? ( >=app-admin/mongo-tools-${PV} )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-4.2.0-fix-scons.patch"
+       "${FILESDIR}/${PN}-4.2.0-fix-scons-third-party.patch"
+       "${FILESDIR}/${PN}-4.0.0-no-compass.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+       if [[ -n ${REPLACING_VERSIONS} ]]; then
+               if ver_test "$REPLACING_VERSIONS" -lt 4.0; then
+                       ewarn "To upgrade from a version earlier than the 4.0-series, you must"
+                       ewarn "successively upgrade major releases until you have upgraded"
+                       ewarn "to 4.0-series. Then upgrade to 4.2 series."
+               else
+                       ewarn "Be sure to set featureCompatibilityVersion to 4.0 before upgrading."
+               fi
+       fi
+}
+
+pkg_setup() {
+       enewgroup mongodb
+       enewuser mongodb -1 -1 /var/lib/${PN} mongodb
+
+       python-any-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       # remove bundled libs
+       rm -r src/third_party/{boost-*,pcre-*,scons-*,snappy-*,yaml-cpp-*,zlib-*,zstandard-*} || die
+
+       # remove compass
+       rm -r src/mongo/installer/compass || die
+}
+
+src_configure() {
+       # https://github.com/mongodb/mongo/wiki/Build-Mongodb-From-Source
+       # --use-system-icu fails tests
+       # --use-system-tcmalloc is strongly NOT recommended:
+       scons_opts=(
+               CC="$(tc-getCC)"
+               CXX="$(tc-getCXX)"
+
+               --disable-warnings-as-errors
+               --use-system-boost
+               --use-system-pcre
+               --use-system-snappy
+               --use-system-stemmer
+               --use-system-yaml
+               --use-system-zlib
+               --use-system-zstd
+       )
+
+       use debug && scons_opts+=( --dbg=on )
+       use kerberos && scons_opts+=( --use-sasl-client )
+       use lto && scons_opts+=( --lto=on )
+       use ssl && scons_opts+=( --ssl )
+
+       # respect mongoDB upstream's basic recommendations
+       # see bug #536688 and #526114
+       if ! use debug; then
+               filter-flags '-m*'
+               filter-flags '-O?'
+       fi
+
+       default
+}
+
+src_compile() {
+       escons "${scons_opts[@]}" core tools
+}
+
+# FEATURES="test -usersandbox" emerge dev-db/mongodb
+src_test() {
+       "${EPYTHON}" ./buildscripts/resmoke.py --dbpathPrefix=test --suites core --jobs=$(makeopts_jobs) || die "Tests failed"
+}
+
+src_install() {
+       escons "${scons_opts[@]}" --nostrip install --prefix="${ED}"/usr
+
+       doman debian/mongo*.1
+       dodoc README docs/building.md
+
+       newinitd "${FILESDIR}/${PN}.initd-r3" ${PN}
+       newconfd "${FILESDIR}/${PN}.confd-r3" ${PN}
+       newinitd "${FILESDIR}/mongos.initd-r3" mongos
+       newconfd "${FILESDIR}/mongos.confd-r3" mongos
+
+       insinto /etc
+       newins "${FILESDIR}/${PN}.conf-r3" ${PN}.conf
+       newins "${FILESDIR}/mongos.conf-r2" mongos.conf
+
+       systemd_dounit "${FILESDIR}/${PN}.service"
+
+       insinto /etc/logrotate.d/
+       newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+       # see bug #526114
+       pax-mark emr "${ED}"/usr/bin/{mongo,mongod,mongos}
+
+       local x
+       for x in /var/{lib,log}/${PN}; do
+               diropts -m0750 -o mongodb -g mongodb
+               keepdir "${x}"
+       done
+}
+
+pkg_postinst() {
+       ewarn "Make sure to read the release notes and follow the upgrade process:"
+       ewarn "  https://docs.mongodb.com/manual/release-notes/$(ver_cut 1-2)/"
+       ewarn "  https://docs.mongodb.com/manual/release-notes/$(ver_cut 1-2)/#upgrade-procedures"
+}