dev-python/jpype: Replace distutils-r1 EXAMPLES use
authorDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:28 +0000 (10:56 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:28 +0000 (10:56 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/jpype/jpype-0.6.2.ebuild
dev-python/jpype/jpype-0.6.3.ebuild

index fda8e06d3cace716bc77270ced719d72a1bb06bf..11d20268eeb9d7c75f2b3af00782f9c9f8248ed4 100644 (file)
@@ -26,6 +26,10 @@ PATCHES=( "${FILESDIR}"/${PN}-gcc6-noexcept.patch )
 
 python_install() {
        use doc && local DOCS=( doc/* )
-       use examples && local EXAMPLES=( examples/. )
+       if use examples; then
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
        distutils-r1_python_install
 }
index 82ec219eac2498e9ae83c040082695246be2f914..f2ea32b2540f23a293d834d00a8f2a2983b4553d 100644 (file)
@@ -26,6 +26,10 @@ DEPEND="
 
 python_install() {
        use doc && local DOCS=( doc/* )
-       use examples && local EXAMPLES=( examples/. )
+       if use examples; then
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
        distutils-r1_python_install
 }