media-libs/liblscp-9999: added live ebuild
authorMiroslav Šulc <fordfrog@gentoo.org>
Fri, 13 Dec 2019 10:47:53 +0000 (11:47 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Fri, 13 Dec 2019 10:47:53 +0000 (11:47 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-libs/liblscp/liblscp-9999.ebuild [new file with mode: 0644]

diff --git a/media-libs/liblscp/liblscp-9999.ebuild b/media-libs/liblscp/liblscp-9999.ebuild
new file mode 100644 (file)
index 0000000..de7d7ff
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools subversion
+
+DESCRIPTION="C++ library for the Linux Sampler control protocol"
+HOMEPAGE="https://www.linuxsampler.org"
+ESVN_REPO_URI="https://svn.linuxsampler.org/svn/liblscp/trunk"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS ChangeLog TODO NEWS README )
+
+src_prepare() {
+       default
+
+       emake -f Makefile.svn
+       eautoreconf
+}
+
+src_configure() {
+       econf --disable-static
+}
+
+src_install() {
+       use doc && local HTML_DOCS=( doc/html/. )
+       default
+       find "${D}" -name '*.la' -delete || die
+}