projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
053e036
)
sys-libs/newlib: add early error for msp430
author
Sergei Trofimovich
<slyfox@gentoo.org>
Thu, 16 Apr 2020 07:42:33 +0000
(08:42 +0100)
committer
Sergei Trofimovich
<slyfox@gentoo.org>
Thu, 16 Apr 2020 07:43:00 +0000
(08:43 +0100)
Reported-by: tomtom69
Bug: https://bugs.gentoo.org/717610
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/newlib/newlib-3.3.0.ebuild
patch
|
blob
|
history
diff --git
a/sys-libs/newlib/newlib-3.3.0.ebuild
b/sys-libs/newlib/newlib-3.3.0.ebuild
index db1a3fad9cfbcd93f7b51cd1a7f40a9bec9f1535..95217157d87a7824e1fd89de4654277e628ab33e 100644
(file)
--- a/
sys-libs/newlib/newlib-3.3.0.ebuild
+++ b/
sys-libs/newlib/newlib-3.3.0.ebuild
@@
-48,6
+48,13
@@
pkg_setup() {
*) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
esac
fi
+
+ case ${CTARGET} in
+ msp430*)
+ # bug #717610
+ die "gcc on ${CTARGET} needs older newlib. Use newlib-3.1.0."
+ ;;
+ esac
}
src_configure() {