dev-python/python-mpd: 1.0.0 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 7 Dec 2019 18:34:21 +0000 (19:34 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 7 Dec 2019 22:51:41 +0000 (23:51 +0100)
Closes: https://bugs.gentoo.org/623500
Closes: https://bugs.gentoo.org/653410
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/python-mpd/Manifest
dev-python/python-mpd/metadata.xml
dev-python/python-mpd/python-mpd-1.0.0.ebuild [new file with mode: 0644]

index bcbb882f91f672e909f82c0a3649dad6edc662ff..9f4c5b34b03bbe35fcf6490787cec6b15f989f86 100644 (file)
@@ -1 +1,2 @@
 DIST python-mpd-0.5.5.tar.gz 46334 BLAKE2B b0345c6ac2027e3881f3f2aaa6d7bc01dcf67b71de9bdd6d6a8b1bbd6f72ff9463100a0850db4320ce7ee818a1212537be68ecb624984e3f40f1ef4102eca075 SHA512 d5eec60045561a8a0e29eda2ec2fc341c9b81d61363260c884f0863e931077c31c32534e3c98a488ef31aa61cd3d21bdcfa625b7b062ef24bf3e8024dc1e7c5a
+DIST python-mpd-1.0.0.tar.gz 60032 BLAKE2B 9293dfc85363f83041b1d73046dabe6a3243a63de495ba630eedbda96d1b080cfb1cc635801794a91103bbd4b9145733d63ce3ad252748d01ed596cd3b0f7895 SHA512 5fab12d082be39ac4a3477ea10b5d1fa350ceac23c97fb12a46f6cd0cfa6a83999f31528d6d7f74c1ffe67f4e63dfbe8fd3debcf917a6e3705bcf84a55a458ce
index 2026acc8e10009fc4b84df60ff062006b8744523..ff857238fdf21a300c868116f28ec75ad74eb41d 100644 (file)
@@ -1,12 +1,15 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-  <maintainer type="project">
-    <email>python@gentoo.org</email>
-    <name>Python</name>
-  </maintainer>
-  <upstream>
-    <remote-id type="pypi">python-mpd</remote-id>
-    <remote-id type="github">Mic92/python-mpd2</remote-id>
-  </upstream>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+               <name>Python</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="pypi">python-mpd</remote-id>
+               <remote-id type="github">Mic92/python-mpd2</remote-id>
+       </upstream>
+       <use>
+               <flag name="twisted">Enable twisted support</flag>
+       </use>
 </pkgmetadata>
diff --git a/dev-python/python-mpd/python-mpd-1.0.0.ebuild b/dev-python/python-mpd/python-mpd-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..067a3f0
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python MPD client library"
+HOMEPAGE="https://github.com/Mic92/python-mpd2"
+SRC_URI="https://github.com/Mic92/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test +twisted"
+
+REQUIRED_USE="test? ( twisted )"
+
+BDEPEND="
+       test? (
+               dev-python/filelock[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/toml[${PYTHON_USEDEP}]
+               dev-python/tox[${PYTHON_USEDEP}]
+       )
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="twisted? ( dev-python/twisted[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="!test? ( test )"
+
+DOCS=( doc/changes.rst doc/topics/{advanced,commands,getting-started,logging}.rst README.rst )
+
+S="${WORKDIR}/${PN}2-${PV}"
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+       rm tox.ini || die
+}