dev-python/python-xmlsec: New package
authorPatrick McLean <patrick.mclean@sony.com>
Tue, 25 Feb 2020 01:33:50 +0000 (17:33 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Tue, 25 Feb 2020 02:05:06 +0000 (18:05 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/python-xmlsec/Manifest [new file with mode: 0644]
dev-python/python-xmlsec/metadata.xml [new file with mode: 0644]
dev-python/python-xmlsec/python-xmlsec-1.3.6.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-xmlsec/Manifest b/dev-python/python-xmlsec/Manifest
new file mode 100644 (file)
index 0000000..5a85047
--- /dev/null
@@ -0,0 +1 @@
+DIST python-xmlsec-1.3.6.tar.gz 51174 BLAKE2B e6571d16268450c5e144aae8da5be42a6aa20f239859c0a5a85f5e20f361d5d85b85772cd5cdd296f2fb9da5f3dffbb869d537bd96fe68b7d4495bb378471d07 SHA512 ccfbe4c8266a5340f67331eac35174ae2cc175ce32ea8482c8b9757275466f058a5977ce62f39bce3c3abeda28988455c93302362c7f219d7b88b44ef245e972
diff --git a/dev-python/python-xmlsec/metadata.xml b/dev-python/python-xmlsec/metadata.xml
new file mode 100644 (file)
index 0000000..56cae16
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>chutzpah@gentoo.org</email>
+    <name>Patrick McLean</name>
+  </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-xmlsec/python-xmlsec-1.3.6.ebuild b/dev-python/python-xmlsec/python-xmlsec-1.3.6.ebuild
new file mode 100644 (file)
index 0000000..46ffcb6
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the XML Security Library"
+HOMEPAGE="https://github.com/mehcode/python-xmlsec"
+SRC_URI="https://github.com/mehcode/python-xmlsec/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+       dev-libs/xmlsec:=
+"
+RDEPEND="${DEPEND}
+       dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+       dev-python/pkgconfig[${PYTHON_USEDEP}]
+       dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+# tests fail, has been reported upstream
+# https://github.com/mehcode/python-xmlsec/issues/84
+RESTRICT=test
+
+distutils_enable_tests pytest