sci-physics/root: add new cudnn USE flag
authorGuilherme Amadio <amadio@gentoo.org>
Wed, 11 Mar 2020 16:09:51 +0000 (17:09 +0100)
committerGuilherme Amadio <amadio@gentoo.org>
Thu, 12 Mar 2020 07:21:39 +0000 (08:21 +0100)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
sci-physics/root/metadata.xml
sci-physics/root/root-9999.ebuild

index 8eb44b130ef327277ff549a2bc525986a21fadab..e20aca48cc1406e66fc7781247b34c0de8c77167 100644 (file)
@@ -25,6 +25,7 @@
     <flag name="c++14">Build using the C++14 standard</flag>
     <flag name="c++17">Build using the C++17 standard</flag>
     <flag name="cuda">Enable support for nVidia CUDA</flag>
+    <flag name="cudnn">Enable support for nVidia cuDNN library</flag>
     <flag name="davix">Enable support for DAVIX Data Management Client (https://cern.ch/davix)</flag>
     <flag name="fits">Enable support for images and data from FITS files with <pkg>sci-libs/cfitsio</pkg></flag>
     <flag name="fortran">Compile included Fortran programs</flag>
index 78fe99872047e2fda32cc3d0606ff0445ba65c5c..ba2e0296e350f3170758d7c7d3d843bb6ec3cac0 100644 (file)
@@ -14,7 +14,7 @@ inherit cmake-utils cuda eapi7-ver elisp-common eutils fortran-2 \
 DESCRIPTION="C++ data analysis framework and interpreter from CERN"
 HOMEPAGE="https://root.cern"
 
-IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda +davix debug emacs
+IUSE="+X aqua +asimage +c++11 c++14 c++17 cuda cudnn +davix debug emacs
        +examples fits fftw fortran +gdml graphviz +gsl http libcxx +minuit
        mysql odbc +opengl oracle postgres prefix pythia6 pythia8 +python
        qt5 R +roofit root7 shadow sqlite +ssl +tbb test +tmva +unuran vc
@@ -41,6 +41,7 @@ LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
 REQUIRED_USE="
        ^^ ( c++11 c++14 c++17 )
        cuda? ( tmva !c++17 )
+       cudnn? ( cuda )
        !X? ( !asimage !opengl !qt5 )
        davix? ( ssl xml )
        python? ( ${PYTHON_REQUIRED_USE} )
@@ -81,6 +82,7 @@ CDEPEND="
        )
        asimage? ( media-libs/libafterimage[gif,jpeg,png,tiff] )
        cuda? ( >=dev-util/nvidia-cuda-toolkit-9.0 )
+       cudnn? ( dev-libs/cudnn )
        davix? ( net-libs/davix )
        emacs? ( >=app-editors/emacs-23.1:* )
        fftw? ( sci-libs/fftw:3.0= )
@@ -198,6 +200,7 @@ src_configure() {
                -Dclad=OFF
                -Dcocoa=$(usex aqua)
                -Dcuda=$(usex cuda)
+               -Dcudnn=$(usex cudnn)
                -Dcxxmodules=OFF # requires clang, unstable
                -Ddavix=$(usex davix)
                -Ddcache=OFF