sys-libs/libunwind: add -fcommon workaround for gcc-10, bug #
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 12 Feb 2020 23:42:18 +0000 (23:42 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 12 Feb 2020 23:42:24 +0000 (23:42 +0000)
The source fix is not trivial as it's not clear where global
shloud be defined: in common or per-arch files. Use -fcommon
downstream and leave proper fix to upstream ticket.

Reported-by: Toralf Förster
Closes: https://bugs.gentoo.org/706560
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/libunwind/libunwind-1.2.1-r3.ebuild
sys-libs/libunwind/libunwind-1.3.1.ebuild

index 10fa1ecd3f924cd968bbe54404a55bb9b4726509..9482711db4defb3d8193f4ed36b85165fbcd6018 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
 MY_PV=${PV/_/-}
 MY_P=${PN}-${MY_PV}
-inherit autotools eutils libtool multilib-minimal
+inherit autotools eutils flag-o-matic libtool multilib-minimal
 
 DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
 HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
@@ -62,6 +62,10 @@ src_prepare() {
 
        elibtoolize
        eautoreconf
+
+       # Let's wait for proer fix upstream in https://github.com/libunwind/libunwind/issues/154
+       # Meanwhile workaround for gcc-10 with -fcommon, bug #706560
+       append-cflags -fcommon
 }
 
 multilib_src_configure() {
index e91ad4925c30171982b3a59e6d6627a75be89712..908da4b4c86df263b3d317a87e04e7aacd72c4f2 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
 MY_PV=${PV/_/-}
 MY_P=${PN}-${MY_PV}
-inherit autotools eutils libtool multilib-minimal
+inherit autotools eutils flag-o-matic libtool multilib-minimal
 
 DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
 HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
@@ -58,6 +58,10 @@ src_prepare() {
 
        elibtoolize
        eautoreconf
+
+       # Let's wait for proer fix upstream in https://github.com/libunwind/libunwind/issues/154
+       # Meanwhile workaround for gcc-10 with -fcommon, bug #706560
+       append-cflags -fcommon
 }
 
 multilib_src_configure() {