dev-python/intelhex: Enable tests, py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Mar 2020 16:55:23 +0000 (17:55 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Mar 2020 16:55:48 +0000 (17:55 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/intelhex/intelhex-2.2.1-r1.ebuild [moved from dev-python/intelhex/intelhex-2.2.1.ebuild with 59% similarity]

similarity index 59%
rename from dev-python/intelhex/intelhex-2.2.1.ebuild
rename to dev-python/intelhex/intelhex-2.2.1-r1.ebuild
index 2b8b2111c4e24e43e1d18dc3e1c2cef8657cc3d4..a2f38563881d66d535d8efaa4d72b30febe0f3b3 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -13,3 +13,13 @@ SRC_URI="mirror://pypi/I/IntelHex/${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~mips ~x86"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+       # upstream don't run their own tests when releasing...
+       [[ ${PV} == 2.2.1 ]] || die "Revisit on bump"
+       sed -i -e 's:2.2:&.1:' scripts/*.py || die
+
+       distutils-r1_src_prepare
+}