mail-client/aerc: add live ebuild
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 5 Mar 2020 06:08:22 +0000 (22:08 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 5 Mar 2020 06:09:20 +0000 (22:09 -0800)
notmuch support not much tested, open bugs if you encounter issues!

Package-Manager: Portage-2.3.92, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
mail-client/aerc/aerc-9999.ebuild [new file with mode: 0644]
mail-client/aerc/metadata.xml

diff --git a/mail-client/aerc/aerc-9999.ebuild b/mail-client/aerc/aerc-9999.ebuild
new file mode 100644 (file)
index 0000000..455ac92
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 go-module
+
+DESCRIPTION="Email client for your terminal"
+HOMEPAGE="https://aerc-mail.org"
+
+EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/aerc"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+IUSE="notmuch"
+
+BDEPEND=">=app-text/scdoc-1.9.7"
+DEPEND="notmuch? ( net-mail/notmuch:= )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+       git-r3_src_unpack
+       go-module_live_vendor
+}
+
+src_compile() {
+       use notmuch && export GOFLAGS="-tags=notmuch"
+       emake PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+       emake PREFIX="${EPREFIX}/usr" DESTDIR="${ED}" install
+       einstalldocs
+}
+
+pkg_postinst() {
+       if [[ -z ${REPLACING_VERSIONS} ]]; then
+               elog "If you want to allow your users to activate html email"
+               elog "processing via w3m as shown in the tutorial, make sure you"
+               elog "emerge net-proxy/dante and www-client/w3m"
+       fi
+
+       local v
+       for v in ${REPLACING_VERSIONS}; do
+               if ver_test $v -lt 0.3.0-r1; then
+                       elog "The dependencies on net-proxy/dante and www-client/w3m"
+                       elog "have been removed since they are optional."
+                       elog "Please emerge them before the next --depclean if you"
+                       elog "need to use them."
+               fi
+       done
+}
index e0d10bf223c0a3ecbc539ca0e0b9528410ca040a..b9e1b88aa68bbdbcfb2288f1673bb759c9bef281 100644 (file)
@@ -5,6 +5,9 @@
                <email>gyakovlev@gentoo.org</email>
                <name>Georgy Yakovlev</name>
        </maintainer>
+       <use>
+               <flag name="notmuch">Enable support for <pkg>net-mail/notmuch</pkg></flag>
+       </use>
        <longdescription lang="en">
                Terminal email client with Vim-style keybindings, git awareness and other advanced features.
        </longdescription>