sci-astronomy/stellarium: enable test
authorAlexey Sokolov <sokolov@google.com>
Fri, 9 Nov 2018 00:32:43 +0000 (00:32 +0000)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 12 Nov 2018 23:00:27 +0000 (00:00 +0100)
Signed-off-by: Alexey Sokolov <sokolov@google.com>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sci-astronomy/stellarium/stellarium-0.18.2.ebuild

index 5e6e6cc48c885450fa95642ba5cd70a24cf91d3a..25ffaeb162c04c0c8b45b93546e31dc912655d0b 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit cmake-utils desktop flag-o-matic gnome2-utils
+inherit cmake-utils desktop flag-o-matic gnome2-utils virtualx
 
 DESCRIPTION="3D photo-realistic skies in real time"
 HOMEPAGE="http://www.stellarium.org/"
@@ -22,9 +22,7 @@ PATCHES=( "${FILESDIR}"/${P}.patch )
 LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug gps media nls stars"
-
-RESTRICT="test" # There are no tests
+IUSE="debug gps media nls stars test"
 
 RDEPEND="
        dev-qt/qtcore:5
@@ -43,8 +41,9 @@ RDEPEND="
 "
 DEPEND="${RDEPEND}
        dev-qt/qtconcurrent:5
-       dev-qt/qttest:5
-       nls? ( dev-qt/linguist-tools:5 )"
+       nls? ( dev-qt/linguist-tools:5 )
+       test? ( dev-qt/qttest:5 )
+"
 
 LANGS=(
        af am ar as ast az be bg bn bo br bs ca cs
@@ -82,10 +81,15 @@ src_configure() {
                -DENABLE_GPS="$(usex gps)"
                -DENABLE_NLS="$(usex nls)"
                -DENABLE_MEDIA="$(usex media)"
+               -DENABLE_TESTING="$(usex test)"
        )
        cmake-utils_src_configure
 }
 
+src_test() {
+       virtx cmake-utils_src_test
+}
+
 src_install() {
        cmake-utils_src_install