app-mobilephone/obexftp: remove unused patches
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Sat, 19 Aug 2017 12:56:51 +0000 (14:56 +0200)
committerMichael Palimaka <kensington@gentoo.org>
Sat, 2 Sep 2017 14:46:01 +0000 (00:46 +1000)
app-mobilephone/obexftp/files/obexftp-0.23-fix-ruby19.patch [deleted file]
app-mobilephone/obexftp/files/obexftp-0.23-fixruby.patch [deleted file]

diff --git a/app-mobilephone/obexftp/files/obexftp-0.23-fix-ruby19.patch b/app-mobilephone/obexftp/files/obexftp-0.23-fix-ruby19.patch
deleted file mode 100644 (file)
index a2ed681..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-Replace functions removed with ruby 1.9
-See also http://dev.zuckschwerdt.org/openobex/ticket/49
-
-
-diff --git a/swig/charmap.i b/swig/charmap.i
-index e1f1fc1..b8e17de 100644
---- a/swig/charmap.i
-+++ b/swig/charmap.i
-@@ -89,8 +89,8 @@
-       $2 = PyString_Size($input);
- #elif defined SWIGRUBY
- /* VALUE str = StringValue($input); // perhaps better? */
--      $1 = STR2CSTR($input);
--      $2 = (int) RSTRING($input)->len;
-+      $1 = StringValuePtr($input);
-+      $2 = (int) RSTRING_LEN($input);
- #elif defined SWIGTCL
-       $1 = Tcl_GetStringFromObj($input,&$2);
- #else
-diff --git a/swig/ruby/ruby_wrap.c b/swig/ruby/ruby_wrap.c
-index 57e40bf..31b1a9d 100644
---- a/swig/ruby/ruby_wrap.c
-+++ b/swig/ruby/ruby_wrap.c
-@@ -2579,8 +2579,8 @@ _wrap_Client_put_data(int argc, VALUE *argv, VALUE self) {
-     
-     
-     /* VALUE str = StringValue(argv[0]); // perhaps better? */
--    arg2 = STR2CSTR(argv[0]);
--    arg3 = (int) RSTRING(argv[0])->len;
-+    arg2 = StringValuePtr(argv[0]);
-+    arg3 = (int) RSTRING_LEN(argv[0]);
-     
-     
-     
--- 
-1.8.4.2
-
diff --git a/app-mobilephone/obexftp/files/obexftp-0.23-fixruby.patch b/app-mobilephone/obexftp/files/obexftp-0.23-fixruby.patch
deleted file mode 100644 (file)
index c7f69ff..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/swig/ruby/Makefile.am
-+++ b/swig/ruby/Makefile.am
-@@ -12,7 +12,7 @@ Makefile.ruby: extconf.rb
-       PREFIX=$(prefix) $(RUBY) $< --with-obexftp-include=$(top_srcdir)
- obexftp.so: ruby_wrap.c Makefile.ruby
--      $(MAKE) -fMakefile.ruby
-+      $(MAKE) -fMakefile.ruby LIBPATH="-Wl,-rpath-link,../../bfb/.libs -Wl,-rpath-link,../../multicobex/.libs -Wl,-rpath-link,../../obexftp/.libs -L../../bfb/.libs -L../../multicobex/.libs -L../../obexftp/.libs"
- install-data-local: Makefile.ruby
-       $(MAKE) -j1 -fMakefile.ruby install