media-libs/gegl: epatch->PATCHES=()
authorMarty E. Plummer <hanetzer@startmail.com>
Fri, 20 Apr 2018 14:29:04 +0000 (09:29 -0500)
committerSebastian Pipping <sping@gentoo.org>
Sat, 21 Apr 2018 20:56:09 +0000 (22:56 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

media-libs/gegl/gegl-0.2.0-r4.ebuild
media-libs/gegl/gegl-0.2.0-r5.ebuild
media-libs/gegl/gegl-0.3.20.ebuild
media-libs/gegl/gegl-0.3.24.ebuild
media-libs/gegl/gegl-0.3.26.ebuild
media-libs/gegl/gegl-0.3.28.ebuild
media-libs/gegl/gegl-0.3.30.ebuild
media-libs/gegl/gegl-0.3.8.ebuild

index ddb70a4e401db46b38f4ee8e22f5de79ce7b638c..2268786841ab6ee4a5104773d306ac54a14b8753 100644 (file)
@@ -54,15 +54,26 @@ DEPEND="${RDEPEND}
 
 DOCS=( ChangeLog INSTALL README NEWS )
 
-src_prepare() {
+PATCHES=(
        # https://bugs.gentoo.org/show_bug.cgi?id=442016
-       epatch "${FILESDIR}/${P}-cve-2012-4433-1e92e523.patch"
-       epatch "${FILESDIR}/${P}-cve-2012-4433-4757cdf7.patch"
+       "${FILESDIR}/${P}-cve-2012-4433-1e92e523.patch"
+       "${FILESDIR}/${P}-cve-2012-4433-4757cdf7.patch"
 
        # https://bugs.gentoo.org/show_bug.cgi?id=416587
-       epatch "${FILESDIR}/${P}-introspection-version.patch"
+       "${FILESDIR}/${P}-introspection-version.patch"
+
+       "${FILESDIR}/${P}-ffmpeg-0.11.diff"
+       "${FILESDIR}"/${P}-g_log_domain.patch
+
+       # https://bugs.gentoo.org/show_bug.cgi?id=605216
+       # https://bugs.gentoo.org/show_bug.cgi?id=617430
+       "${FILESDIR}"/${P}-underlinking.patch
+       "${FILESDIR}"/${P}-libopenraw-0.1.patch  # bug 639834
+       "${FILESDIR}"/${P}-fix-without-exiv2.patch  # bug 641872
+)
 
-       epatch "${FILESDIR}/${P}-ffmpeg-0.11.diff"
+src_prepare() {
+       default
        # fix OSX loadable module filename extension
        sed -i -e 's/\.dylib/.bundle/' configure.ac || die
        # don't require Apple's OpenCL on versions of OSX that don't have it
@@ -70,15 +81,6 @@ src_prepare() {
                sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
        fi
 
-       epatch "${FILESDIR}"/${P}-g_log_domain.patch
-
-       # https://bugs.gentoo.org/show_bug.cgi?id=605216
-       # https://bugs.gentoo.org/show_bug.cgi?id=617430
-       epatch "${FILESDIR}"/${P}-underlinking.patch
-       epatch "${FILESDIR}"/${P}-libopenraw-0.1.patch  # bug 639834
-       epatch "${FILESDIR}"/${P}-fix-without-exiv2.patch  # bug 641872
-
-       eapply_user
        eautoreconf
 
        # https://bugs.gentoo.org/show_bug.cgi?id=468248
index 717ad1841b638c381713a26065b9d330ecb8bbcc..cd6b1554809ad733fe6451376387d901d1a62499 100644 (file)
@@ -54,18 +54,30 @@ DEPEND="${RDEPEND}
 
 DOCS=( ChangeLog INSTALL README NEWS )
 
-src_prepare() {
+PATCHES=(
        # https://bugs.gentoo.org/show_bug.cgi?id=636780
-       epatch "${FILESDIR}/${P}-ffmpeg-av_frame_alloc.patch"
+       "${FILESDIR}/${P}-ffmpeg-av_frame_alloc.patch"
 
        # https://bugs.gentoo.org/show_bug.cgi?id=442016
-       epatch "${FILESDIR}/${P}-cve-2012-4433-1e92e523.patch"
-       epatch "${FILESDIR}/${P}-cve-2012-4433-4757cdf7.patch"
+       "${FILESDIR}/${P}-cve-2012-4433-1e92e523.patch"
+       "${FILESDIR}/${P}-cve-2012-4433-4757cdf7.patch"
 
        # https://bugs.gentoo.org/show_bug.cgi?id=416587
-       epatch "${FILESDIR}/${P}-introspection-version.patch"
+       "${FILESDIR}/${P}-introspection-version.patch"
+
+       "${FILESDIR}/${P}-ffmpeg-0.11.diff"
+       "${FILESDIR}"/${P}-g_log_domain.patch
+
+       # https://bugs.gentoo.org/show_bug.cgi?id=605216
+       # https://bugs.gentoo.org/show_bug.cgi?id=617430
+       "${FILESDIR}"/${P}-underlinking.patch
+       "${FILESDIR}"/${P}-libopenraw-0.1.patch  # bug 639834
+       "${FILESDIR}"/${P}-fix-without-exiv2.patch  # bug 641872
+
+)
 
-       epatch "${FILESDIR}/${P}-ffmpeg-0.11.diff"
+src_prepare() {
+       default
        # fix OSX loadable module filename extension
        sed -i -e 's/\.dylib/.bundle/' configure.ac || die
        # don't require Apple's OpenCL on versions of OSX that don't have it
@@ -73,15 +85,6 @@ src_prepare() {
                sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
        fi
 
-       epatch "${FILESDIR}"/${P}-g_log_domain.patch
-
-       # https://bugs.gentoo.org/show_bug.cgi?id=605216
-       # https://bugs.gentoo.org/show_bug.cgi?id=617430
-       epatch "${FILESDIR}"/${P}-underlinking.patch
-       epatch "${FILESDIR}"/${P}-libopenraw-0.1.patch  # bug 639834
-       epatch "${FILESDIR}"/${P}-fix-without-exiv2.patch  # bug 641872
-
-       eapply_user
        eautoreconf
 
        # https://bugs.gentoo.org/show_bug.cgi?id=468248
index 6afa0cc4600d4b9a1e6d987e1208cbc7493ea42c..ca8af3a92928efc100c8c4e78639e323150d2344 100644 (file)
@@ -75,6 +75,10 @@ pkg_setup() {
        use test && use introspection && python-any-r1_pkg_setup
 }
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
 src_prepare() {
        default
 
@@ -91,8 +95,6 @@ src_prepare() {
                -e '/composite-transform.xml/d' \
                -i tests/compositions/Makefile.am || die
 
-       epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
-
        eautoreconf
 
        gnome2_environment_reset
index 4dc1c361007693f9faac292a92a3e0106a0d8909..725be5c3b377e8cd7af6210559512bdb151679a0 100644 (file)
@@ -75,6 +75,10 @@ pkg_setup() {
        use test && use introspection && python-any-r1_pkg_setup
 }
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
 src_prepare() {
        default
 
@@ -91,8 +95,6 @@ src_prepare() {
                -e '/composite-transform.xml/d' \
                -i tests/compositions/Makefile.am || die
 
-       epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
-
        eautoreconf
 
        gnome2_environment_reset
index 7aa01eab364d210637da28ad0b831a7c99ab217a..aaf6fcd179ba339914afaf555c5ce4d3e38b06f4 100644 (file)
@@ -75,6 +75,10 @@ pkg_setup() {
        use test && use introspection && python-any-r1_pkg_setup
 }
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
 src_prepare() {
        default
 
@@ -91,8 +95,6 @@ src_prepare() {
                -e '/composite-transform.xml/d' \
                -i tests/compositions/Makefile.am || die
 
-       epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
-
        eautoreconf
 
        gnome2_environment_reset
index 863f2e51ff1d5246861c4aa29c6d52e258c63f66..7ca15acd39e0b190c3b1495c55ed0970efe2ef31 100644 (file)
@@ -75,6 +75,10 @@ pkg_setup() {
        use test && use introspection && python-any-r1_pkg_setup
 }
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
 src_prepare() {
        default
 
@@ -91,8 +95,6 @@ src_prepare() {
                -e '/composite-transform.xml/d' \
                -i tests/compositions/Makefile.am || die
 
-       epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
-
        eautoreconf
 
        gnome2_environment_reset
index 7ea4b3acef94a63424d4c7f1967691dda22a1225..6ca6a617b1734e595c6023befb69c2c4a2216af3 100644 (file)
@@ -75,6 +75,10 @@ pkg_setup() {
        use test && use introspection && python-any-r1_pkg_setup
 }
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
 src_prepare() {
        default
 
@@ -91,8 +95,6 @@ src_prepare() {
                -e '/composite-transform.xml/d' \
                -i tests/compositions/Makefile.am || die
 
-       epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
-
        eautoreconf
 
        gnome2_environment_reset
index 92e02f5f4eb884b994a7cd2d6d1f7c1a49274fdd..519fc73056377c8146c2df4c21be3596ad012575 100644 (file)
@@ -75,6 +75,11 @@ pkg_setup() {
        use test && use introspection && python-any-r1_pkg_setup
 }
 
+PATCHES=(
+       #"${FILESDIR}"/${P}-g_log_domain.patch
+       "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
 src_prepare() {
        default
 
@@ -86,15 +91,11 @@ src_prepare() {
                sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
        fi
 
-       #epatch "${FILESDIR}"/${P}-g_log_domain.patch
-
        # commit 7c78497b : tests that use gegl.png are broken on non-amd64
        sed -e '/clones.xml/d' \
                -e '/composite-transform.xml/d' \
                -i tests/compositions/Makefile.am || die
 
-       epatch "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
-
        eautoreconf
 
        gnome2_environment_reset