sys-libs/libselinux: drop old
authorJason Zaman <perfinion@gentoo.org>
Sat, 17 Aug 2019 09:02:16 +0000 (17:02 +0800)
committerJason Zaman <perfinion@gentoo.org>
Sat, 17 Aug 2019 09:02:16 +0000 (17:02 +0800)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
sys-libs/libselinux/Manifest
sys-libs/libselinux/libselinux-2.9_rc1.ebuild [deleted file]

index 33ec840d9b94e7215f48dfa0e21d1fba4db0cd56..094206150ecd3cb1c6c5561b9ba409cc11b86e0e 100644 (file)
@@ -1,3 +1,2 @@
 DIST libselinux-2.8.tar.gz 187759 BLAKE2B 1e0e1a5aa2230fd6080e921efe871e97fa9412176b72a0c9721f60c6190459e508644fa3370f3b5f513f088428844c7c615cda4567990ddee91c13e1ee88f9ed SHA512 2f15d08888fbef9b0cf7bf01893b513edc6738974e2d0eab7e3f79cef9be79cf966742b0d2693b5d2ec7defddb5f4d6c6f6280be9d4158ed41f7a18d50b9f019
-DIST libselinux-2.9-rc1.tar.gz 187984 BLAKE2B e1940ca839d73477593c5e530124f856db518ba682495889e9aac595d8bb0b4e5bff714c654ce896111648159e79cca7f449e94b05fe8cc40bf73180a2c03efd SHA512 15c068b7ad2852a3b6db9a5e192981de8f8257ae4e7f8b57c92755e74c0b5b03ad5489505a84d483fda16b879a20839914eb6a2ee563e37f01f6b3a9ac9c596d
 DIST libselinux-2.9.tar.gz 211546 BLAKE2B 5b06b922690e48924865c98ed34ebfc1ce5e30e78dbeaccb6b9c931a35bed113c030f8f8575084429fe13b91aeafc73abaa24fe609a17ba54c8472d783f6ac61 SHA512 727b211d09f374d45aa3fa4dec7fd5463dfdcf5aaa47f7fcaccee51fb74896c3aa1a6f0bac9cdd47ebe4929effff13f66f5f70447b27b783dca5f7b1576d30d0
diff --git a/sys-libs/libselinux/libselinux-2.9_rc1.ebuild b/sys-libs/libselinux/libselinux-2.9_rc1.ebuild
deleted file mode 100644 (file)
index a92de2e..0000000
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
-USE_RUBY="ruby24 ruby25"
-
-# No, I am not calling ruby-ng
-inherit multilib python-r1 toolchain-funcs multilib-minimal
-
-MY_P="${P//_/-}"
-SEPOL_VER="${PV}"
-MY_RELEASEDATE="20190125"
-
-DESCRIPTION="SELinux userland library"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
-if [[ ${PV} == 9999 ]] ; then
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
-       S="${WORKDIR}/${MY_P}/${PN}"
-else
-       SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
-       S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="public-domain"
-SLOT="0"
-IUSE="pcre2 python ruby static-libs ruby_targets_ruby24 ruby_targets_ruby25"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}:=[${MULTILIB_USEDEP}]
-       !pcre2? ( >=dev-libs/libpcre-8.33-r1:=[static-libs?,${MULTILIB_USEDEP}] )
-       pcre2? ( dev-libs/libpcre2:=[static-libs?,${MULTILIB_USEDEP}] )
-       python? ( ${PYTHON_DEPS} )
-       ruby? (
-               ruby_targets_ruby24? ( dev-lang/ruby:2.4 )
-               ruby_targets_ruby25? ( dev-lang/ruby:2.5 )
-       )
-       elibc_musl? ( sys-libs/fts-standalone )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       python? ( >=dev-lang/swig-2.0.9 )
-       ruby? ( >=dev-lang/swig-2.0.9 )"
-
-src_prepare() {
-       eapply_user
-
-       multilib_copy_sources
-}
-
-multilib_src_compile() {
-       tc-export AR CC PKG_CONFIG RANLIB
-
-       emake \
-               LIBDIR="\$(PREFIX)/$(get_libdir)" \
-               SHLIBDIR="/$(get_libdir)" \
-               LDFLAGS="-fPIC ${LDFLAGS} -pthread" \
-               USE_PCRE2="$(usex pcre2 y n)" \
-               FTS_LDLIBS="$(usex elibc_musl '-lfts' '')" \
-               all
-
-       if multilib_is_native_abi && use python; then
-               building() {
-                       emake \
-                               LDFLAGS="-fPIC ${LDFLAGS} -lpthread" \
-                               LIBDIR="\$(PREFIX)/$(get_libdir)" \
-                               SHLIBDIR="/$(get_libdir)" \
-                               USE_PCRE2="$(usex pcre2 y n)" \
-                               FTS_LDLIBS="$(usex elibc_musl '-lfts' '')" \
-                               pywrap
-               }
-               python_foreach_impl building
-       fi
-
-       if multilib_is_native_abi && use ruby; then
-               building() {
-                       einfo "Calling rubywrap for ${1}"
-                       # Clean up .lo file to force rebuild
-                       rm -f src/selinuxswig_ruby_wrap.lo || die
-                       emake \
-                               RUBY=${1} \
-                               LDFLAGS="-fPIC ${LDFLAGS} -lpthread" \
-                               LIBDIR="\$(PREFIX)/$(get_libdir)" \
-                               SHLIBDIR="/$(get_libdir)" \
-                               USE_PCRE2="$(usex pcre2 y n)" \
-                               FTS_LDLIBS="$(usex elibc_musl '-lfts' '')" \
-                               rubywrap
-               }
-               for RUBYTARGET in ${USE_RUBY}; do
-                       use ruby_targets_${RUBYTARGET} || continue
-
-                       building ${RUBYTARGET}
-               done
-       fi
-}
-
-multilib_src_install() {
-       emake DESTDIR="${D}" \
-               LIBDIR="\$(PREFIX)/$(get_libdir)" \
-               SHLIBDIR="/$(get_libdir)" \
-               USE_PCRE2="$(usex pcre2 y n)" \
-               install
-
-       if multilib_is_native_abi && use python; then
-               installation() {
-                       emake DESTDIR="${D}" \
-                               LIBDIR="\$(PREFIX)/$(get_libdir)" \
-                               SHLIBDIR="/$(get_libdir)" \
-                               USE_PCRE2="$(usex pcre2 y n)" \
-                               install-pywrap
-                       python_optimize # bug 531638
-               }
-               python_foreach_impl installation
-       fi
-
-       if multilib_is_native_abi && use ruby; then
-               installation() {
-                       einfo "Calling install-rubywrap for ${1}"
-                       # Forcing (re)build here as otherwise the resulting SO file is used for all ruby versions
-                       rm src/selinuxswig_ruby_wrap.lo
-                       emake DESTDIR="${D}" \
-                               LIBDIR="\$(PREFIX)/$(get_libdir)" \
-                               SHLIBDIR="/$(get_libdir)" \
-                               RUBY=${1} \
-                               USE_PCRE2="$(usex pcre2 y n)" \
-                               install-rubywrap
-               }
-               for RUBYTARGET in ${USE_RUBY}; do
-                       use ruby_targets_${RUBYTARGET} || continue
-
-                       installation ${RUBYTARGET}
-               done
-       fi
-
-       use static-libs || rm "${D}"/usr/lib*/*.a || die
-}
-
-pkg_postinst() {
-       # Fix bug 473502
-       for POLTYPE in ${POLICY_TYPES};
-       do
-               mkdir -p /etc/selinux/${POLTYPE}/contexts/files || die
-               touch /etc/selinux/${POLTYPE}/contexts/files/file_contexts.local || die
-               # Fix bug 516608
-               for EXPRFILE in file_contexts file_contexts.homedirs file_contexts.local ; do
-                       if [[ -f "/etc/selinux/${POLTYPE}/contexts/files/${EXPRFILE}" ]]; then
-                               sefcontext_compile /etc/selinux/${POLTYPE}/contexts/files/${EXPRFILE} \
-                               || die "Failed to recompile contexts"
-                       fi
-               done
-       done
-}