sys-libs/db: remove USE=rpc support
authorRobin H. Johnson <robbat2@gentoo.org>
Fri, 27 Mar 2020 19:01:35 +0000 (12:01 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Fri, 27 Mar 2020 19:06:52 +0000 (12:06 -0700)
Remove USE=rpc support for all 4.x releases. Upstream removed RPC
support in the 4.8 series, but it was still present in older releases.

The upstream RPC server component (berkeley_db_svc) is single-threaded,
has no security, and other limitations that make it not suited for many
uses.

It could be revived by porting to use libtirpc, see
net-analyzer/argus/files/argus-3.0.8.2-rpc.patch as an example of some
of the required changes.

Fixes: https://bugs.gentoo.org/699750
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
sys-libs/db/db-4.2.52_p5-r3.ebuild [moved from sys-libs/db/db-4.2.52_p5-r2.ebuild with 98% similarity]
sys-libs/db/db-4.3.29_p1-r3.ebuild [moved from sys-libs/db/db-4.3.29_p1-r2.ebuild with 98% similarity]
sys-libs/db/db-4.4.20_p4-r3.ebuild [moved from sys-libs/db/db-4.4.20_p4-r2.ebuild with 98% similarity]
sys-libs/db/db-4.5.20_p2-r3.ebuild [moved from sys-libs/db/db-4.5.20_p2-r2.ebuild with 98% similarity]
sys-libs/db/db-4.6.21_p4-r2.ebuild [moved from sys-libs/db/db-4.6.21_p4-r1.ebuild with 98% similarity]
sys-libs/db/db-4.7.25_p4-r2.ebuild [moved from sys-libs/db/db-4.7.25_p4-r1.ebuild with 98% similarity]
sys-libs/db/metadata.xml

similarity index 98%
rename from sys-libs/db/db-4.2.52_p5-r2.ebuild
rename to sys-libs/db/db-4.2.52_p5-r3.ebuild
index f9454de5eef4a778be82f0ac7b1e5a35b4d38901..a5f249c6a52638f5b7ea2e2169f0b915c3de97b0 100644 (file)
@@ -28,7 +28,7 @@ done
 LICENSE="Sleepycat"
 SLOT="$(ver_cut 1-2)"
 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="tcl java doc cxx rpc"
+IUSE="tcl java doc cxx"
 RESTRICT="!test? ( test )"
 
 DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
@@ -110,7 +110,7 @@ src_configure() {
        local myconf=(
                --enable-compat185
                --with-uniquename
-               $(use_enable rpc)
+               --disable-rpc
                --host="${CHOST}"
 
                $(usex amd64 '--with-mutex=x86/gcc-assembly' '')
similarity index 98%
rename from sys-libs/db/db-4.3.29_p1-r2.ebuild
rename to sys-libs/db/db-4.3.29_p1-r3.ebuild
index 81896b6e565d2ee57882dd704f2d1eeb1c3f5dbe..f208ffd19e6f1555935652422408f6bb8bf19fb7 100644 (file)
@@ -28,7 +28,7 @@ done
 LICENSE="Sleepycat"
 SLOT="$(ver_cut 1-2)"
 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sparc x86"
-IUSE="tcl java doc cxx rpc"
+IUSE="tcl java doc cxx"
 RESTRICT="!test? ( test )"
 
 DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
@@ -112,7 +112,7 @@ src_configure() {
                --enable-compat185
                --enable-o_direct
                --without-uniquename
-               $(use_enable rpc)
+               --disable-rpc
                --host="${CHOST}"
 
                $(usex amd64 '--with-mutex=x86/gcc-assembly' '')
similarity index 98%
rename from sys-libs/db/db-4.4.20_p4-r2.ebuild
rename to sys-libs/db/db-4.4.20_p4-r3.ebuild
index 980ee7aa93e7467192716a80608dd7f79e2dbfdc..dfdea3ae9c22f1d308dd37b751f78f8fe6fcffb2 100644 (file)
@@ -29,7 +29,7 @@ done
 LICENSE="Sleepycat BSD"
 SLOT="$(ver_cut 1-2)"
 KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="tcl java doc cxx rpc"
+IUSE="tcl java doc cxx"
 RESTRICT="!test? ( test )"
 
 DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
@@ -106,7 +106,7 @@ src_configure() {
                --enable-compat185
                --enable-o_direct
                --without-uniquename
-               $(use_enable rpc)
+               --disable-rpc
                --host="${CHOST}"
 
                $(usex amd64 '--with-mutex=x86/gcc-assembly' '')
similarity index 98%
rename from sys-libs/db/db-4.5.20_p2-r2.ebuild
rename to sys-libs/db/db-4.5.20_p2-r3.ebuild
index 3b7360b9467b887abd93656aa94c90424c646a08..3a85922dd9f0c825be9242758baa04c41bb614fa 100644 (file)
@@ -28,7 +28,7 @@ done
 LICENSE="Sleepycat"
 SLOT="$(ver_cut 1-2)"
 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="tcl java doc cxx rpc"
+IUSE="tcl java doc cxx"
 RESTRICT="!test? ( test )"
 
 DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
@@ -116,7 +116,7 @@ src_configure() {
                --enable-compat185
                --enable-o_direct
                --without-uniquename
-               $(use_enable rpc)
+               --disable-rpc
                --host="${CHOST}"
 
                $(usex amd64 '--with-mutex=x86/gcc-assembly' '')
similarity index 98%
rename from sys-libs/db/db-4.6.21_p4-r1.ebuild
rename to sys-libs/db/db-4.6.21_p4-r2.ebuild
index 76bcc6630da89afb8883b1046a9b0dcc04058a3d..f11841a00fa040b8bc461e484b081a0d58521780 100644 (file)
@@ -28,7 +28,7 @@ done
 LICENSE="Sleepycat"
 SLOT="$(ver_cut 1-2)"
 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="tcl java doc cxx rpc"
+IUSE="tcl java doc cxx"
 RESTRICT="!test? ( test )"
 
 DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
@@ -105,7 +105,7 @@ src_configure() {
                --enable-compat185
                --enable-o_direct
                --without-uniquename
-               $(use_enable rpc)
+               --disable-rpc
                --host="${CHOST}"
 
                $(usex amd64 '--with-mutex=x86/gcc-assembly' '')
similarity index 98%
rename from sys-libs/db/db-4.7.25_p4-r1.ebuild
rename to sys-libs/db/db-4.7.25_p4-r2.ebuild
index a75117aac7bfbba8b744f4c87d2600e371c816fa..a6ab5c01d2f776f2a5ed7b8638ac12c5fc5a239b 100644 (file)
@@ -30,7 +30,7 @@ done
 LICENSE="Sleepycat"
 SLOT="$(ver_cut 1-2)"
 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sparc x86"
-IUSE="doc java cxx tcl test rpc"
+IUSE="doc java cxx tcl test"
 
 # the entire testsuite needs the TCL functionality
 DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
@@ -108,7 +108,7 @@ src_configure() {
                --enable-compat185
                --enable-o_direct
                --without-uniquename
-               $(use_enable rpc)
+               --disable-rpc
 
                $(usex amd64 '--with-mutex=x86/gcc-assembly' '')
                $(use_enable cxx)
index 19c65222929a4c65fb2a3a14abbe960646eeceec..4b0876002621871c70e189330fee62cf4f987df9 100644 (file)
@@ -23,7 +23,4 @@ gedeeld geheugen caching en database herstel. DB ondersteund C, C++, Java en
 Perl API's. DB is beschikbaar voor veel UNIX platformen en
 Windows.
 </longdescription>
-<use>
-       <flag name="rpc">Enable rpc client/server</flag>
-</use>
 </pkgmetadata>