dev-python/click-threading: apply distutils_enable_tests, add py37 compat, remove...
authorWim Muskee <wimmuskee@gmail.com>
Sun, 8 Dec 2019 12:52:46 +0000 (13:52 +0100)
committerAaron Bauman <bman@gentoo.org>
Fri, 13 Dec 2019 16:07:43 +0000 (11:07 -0500)
Closes: https://bugs.gentoo.org/660650
Signed-off-by: Wim Muskee <wimmuskee@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/13919
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-python/click-threading/click-threading-0.3.0.ebuild
dev-python/click-threading/click-threading-0.4.4.ebuild

index 0df9ebc7f5280078043c0fc14c5196159218e165..5355a0103c2aea1ed213d01bb8e529f2d12a9e6a 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
 
 inherit distutils-r1
 
@@ -13,15 +13,10 @@ SRC_URI="https://github.com/click-contrib/${PN}/archive/${PV}.tar.gz -> ${P}-gh.
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND=">=dev-python/click-5.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
 
 DOCS=( README.rst )
 
-python_test() {
-       py.test -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest
index 0df9ebc7f5280078043c0fc14c5196159218e165..a61aa16cab9f42c93b57ca3ee96db7a02e1f3f70 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
 
 inherit distutils-r1
 
@@ -13,15 +13,10 @@ SRC_URI="https://github.com/click-contrib/${PN}/archive/${PV}.tar.gz -> ${P}-gh.
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND=">=dev-python/click-5.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
 
 DOCS=( README.rst )
 
-python_test() {
-       py.test -v || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest