2.1.1_rc1-r7 revbump for bugs #144011 and #146564.
authorZac Medico <zmedico@gentoo.org>
Thu, 7 Sep 2006 17:51:38 +0000 (17:51 +0000)
committerZac Medico <zmedico@gentoo.org>
Thu, 7 Sep 2006 17:51:38 +0000 (17:51 +0000)
Package-Manager: portage-2.1.1_rc1-r7

sys-apps/portage/ChangeLog
sys-apps/portage/files/digest-portage-2.1.1_rc1-r7 [new file with mode: 0644]
sys-apps/portage/portage-2.1.1_rc1-r7.ebuild [new file with mode: 0644]

index 12ac9c80da8b6f7ab2afd2a2f65866c9ba4b188f..9874a60bb83d2201c555155f72f1d8b9a27d8c91 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for sys-apps/portage
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.237 2006/09/06 21:17:19 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.238 2006/09/07 17:51:38 zmedico Exp $
+
+*portage-2.1.1_rc1-r7 (07 Sep 2006)
+
+  07 Sep 2006; Zac Medico <zmedico@gentoo.org> +portage-2.1.1_rc1-r7.ebuild:
+  2.1.1_rc1-r7 revbump for bugs #144011 and #146564.
 
 *portage-2.1.1_rc1-r6 (06 Sep 2006)
 
diff --git a/sys-apps/portage/files/digest-portage-2.1.1_rc1-r7 b/sys-apps/portage/files/digest-portage-2.1.1_rc1-r7
new file mode 100644 (file)
index 0000000..748ff38
--- /dev/null
@@ -0,0 +1,12 @@
+MD5 6e7c4a2b1d104d53178eaeb66ddf30ca portage-2.1.1_rc1-r7.patch.bz2 7784
+RMD160 307257b2ea4e2e663b2a27680bf6a94529491259 portage-2.1.1_rc1-r7.patch.bz2 7784
+SHA256 8dd678372a6106fbe28dbb750c8672f430a4e2429dbb523e13672786101869ee portage-2.1.1_rc1-r7.patch.bz2 7784
+MD5 ad76c9fb311fd603e7c3c75f7d5b09c0 portage-2.1.1_rc1.tar.bz2 295029
+RMD160 5c1f8b9bd56843b5248d0be33b702008f9284695 portage-2.1.1_rc1.tar.bz2 295029
+SHA256 d29a6adcb6684c965bfec91796aedbd7ab0cf2bb05794eb1acb79a5408cef95d portage-2.1.1_rc1.tar.bz2 295029
+MD5 c6fe647803cc354a5b8ab22660caeb26 portage-man-pl-2.1-r1.patch.bz2 2076
+RMD160 be3898714b94fb0253c1826909649ea51da205ad portage-man-pl-2.1-r1.patch.bz2 2076
+SHA256 28176c04290478ba4373c28ea047edbdf3a40d3ff69bf92da55d1cfcb828ea5b portage-man-pl-2.1-r1.patch.bz2 2076
+MD5 3a1c6f874490e12965812fa0920c539f portage-man-pl-2.1.tar.bz2 52425
+RMD160 5fdb898b94b0c6bb23234f0903572675f653ff44 portage-man-pl-2.1.tar.bz2 52425
+SHA256 7e01f6c9c567f81d8e81dfdc26cf04b8d1f9f375090641cb80580986f8ac4817 portage-man-pl-2.1.tar.bz2 52425
diff --git a/sys-apps/portage/portage-2.1.1_rc1-r7.ebuild b/sys-apps/portage/portage-2.1.1_rc1-r7.ebuild
new file mode 100644 (file)
index 0000000..145359c
--- /dev/null
@@ -0,0 +1,200 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.1_rc1-r7.ebuild,v 1.1 2006/09/07 17:51:38 zmedico Exp $
+
+inherit toolchain-funcs eutils flag-o-matic
+
+DESCRIPTION="The Portage Package Management System. The primary package management and distribution system for Gentoo."
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+PROVIDE="virtual/portage"
+SLOT="0"
+# USE_EXPAND_HIDDEN hides ELIBC and USERLAND expansions from emerge output (see make.conf.5).
+IUSE_ELIBC="elibc_glibc elibc_uclibc elibc_FreeBSD"
+IUSE_USERLAND="userland_Darwin userland_GNU"
+IUSE="build doc selinux linguas_pl ${IUSE_ELIBC} ${IUSE_USERLAND}"
+DEPEND=">=dev-lang/python-2.3
+       !build? ( >=sys-apps/sed-4.0.5 )"
+RDEPEND=">=dev-lang/python-2.3
+       !build? ( >=sys-apps/sed-4.0.5
+               dev-python/python-fchksum
+               !userland_Darwin? ( >=app-shells/bash-3.0 ) )
+       elibc_glibc? ( sys-apps/sandbox )
+       elibc_uclibc? ( sys-apps/sandbox )
+       !userland_Darwin? ( >=app-misc/pax-utils-0.1.13 )
+       selinux? ( >=dev-python/python-selinux-2.16 )
+       doc? ( app-portage/portage-manpages )
+       >=dev-python/pycrypto-2.0.1-r5"
+SRC_ARCHIVES="http://dev.gentoo.org/~zmedico/portage/archives"
+
+PV_PL="2.1"
+PATCHVER_PL="-r1"
+SRC_URI="mirror://gentoo/${PN}-${PV}.tar.bz2
+       ${SRC_ARCHIVES}/${PN}-${PV}.tar.bz2
+       linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}.tar.bz2
+       ${SRC_ARCHIVES}/${PN}-man-pl-${PV_PL}.tar.bz2 )"
+
+PATCHVER=""
+[ "${PR}" != "r0" ] && PATCHVER="-${PR}"
+if [ -n "${PATCHVER}" ]; then
+       SRC_URI="${SRC_URI} mirror://gentoo/${PN}-${PV}${PATCHVER}.patch.bz2
+       ${SRC_ARCHIVES}/${PN}-${PV}${PATCHVER}.patch.bz2"
+fi
+
+if [ -n "${PATCHVER_PL}" ]; then
+       SRC_URI="${SRC_URI} linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch.bz2
+       ${SRC_ARCHIVES}/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch.bz2 )"
+fi
+
+S="${WORKDIR}"/${PN}-${PV}
+S_PL="${WORKDIR}"/${PN}-${PV_PL}
+
+portage_docs() {
+       elog ""
+       elog "For help with using portage please consult the Gentoo Handbook"
+       elog "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
+       elog ""
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       if [ -n "${PATCHVER}" ]; then
+               cd "${S}"
+               epatch "${WORKDIR}/${PN}-${PV}${PATCHVER}.patch"
+       fi
+       if [ "${PR}" != "r0" ]; then
+               elog "Setting portage.VERSION to ${PVR} ..."
+               sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage.py || \
+                       die "Failed to patch portage.VERSION"
+               eend 0
+       fi
+       if [ -n "${PATCHVER_PL}" ]; then
+               use linguas_pl && \
+                       epatch "${WORKDIR}/${PN}-man-pl-${PV_PL}${PATCHVER_PL}.patch"
+       fi
+}
+
+src_compile() {
+       append-lfs-flags
+
+       cd "${S}"/src
+       $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o tbz2tool tbz2tool.c || \
+               die "Failed to build tbz2tool"
+
+       if use elibc_FreeBSD; then
+               cd "${S}"/src/bsd-flags
+               chmod +x setup.py
+               ./setup.py build || die "Failed to install bsd-chflags module"
+       fi
+}
+
+src_install() {
+       local portage_base="/usr/lib/portage"
+       cd "${S}"/cnf
+       insinto /etc
+       doins etc-update.conf dispatch-conf.conf make.globals
+       if [ -f "make.conf.${ARCH}".diff ]; then
+               patch make.conf "make.conf.${ARCH}".diff || \
+                       die "Failed to patch make.conf.example"
+               newins make.conf make.conf.example
+       else
+               eerror ""
+               eerror "Portage does not have an arch-specific configuration for this arch."
+               eerror "Please notify the arch maintainer about this issue. Using generic."
+               eerror ""
+               newins make.conf make.conf.example
+       fi
+
+       if use elibc_FreeBSD; then
+               cd "${S}"/src/bsd-flags
+               ./setup.py install --root "${D}" || \
+                       die "Failed to install bsd-chflags module"
+       fi
+
+       dodir ${portage_base}/bin
+       exeinto ${portage_base}/bin
+       # BSD and OSX need a sed wrapper so that find/xargs work properly
+       if use userland_GNU; then
+               rm "${S}"/bin/sed || die "Failed to remove sed wrapper"
+       fi
+       cd "${S}"/bin
+       doexe *
+       doexe "${S}"/src/tbz2tool
+       dosym newins ${portage_base}/bin/donewins
+
+       for mydir in pym pym/cache pym/elog_modules; do
+               dodir ${portage_base}/${mydir}
+               insinto ${portage_base}/${mydir}
+               cd "${S}"/${mydir}
+               doins *.py
+       done
+
+       doman "${S}"/man/*.[0-9]
+       if use linguas_pl; then
+               doman -i18n=pl "${S_PL}"/man/pl/*.[0-9]
+               doman -i18n=pl_PL.UTF-8 "${S_PL}"/man/pl_PL.UTF-8/*.[0-9]
+       fi
+       dodoc "${S}"/ChangeLog
+       dodoc "${S}"/NEWS
+       dodoc "${S}"/RELEASE-NOTES
+
+       dodir /usr/bin
+       for x in ebuild emerge portageq repoman tbz2tool xpak; do
+               dosym ../lib/portage/bin/${x} /usr/bin/${x}
+       done
+
+       dodir /usr/sbin
+       local my_syms="archive-conf
+               dispatch-conf
+               emaint
+               emerge-webrsync
+               env-update
+               etc-update
+               fixpackages
+               quickpkg
+               regenworld"
+       local x
+       for x in ${my_syms}; do
+               dosym ../lib/portage/bin/${x} /usr/sbin/${x}
+       done
+
+       dodir /etc/portage
+       keepdir /etc/portage
+
+       doenvd "${FILESDIR}"/05portage.envd
+}
+
+pkg_preinst() {
+       local portage_base="/usr/lib/portage"
+       if has livecvsportage ${FEATURES} && [ "${ROOT}" = "/" ]; then
+               rm -rf "${IMAGE}"/${portage_base}/pym/*
+               mv "${IMAGE}"/${portage_base}/bin/tbz2tool "${T}"
+               rm -rf "${IMAGE}"/${portage_base}/bin/*
+               mv "${T}"/tbz2tool "${IMAGE}"/${portage_base}/bin/
+       else
+               for mydir in pym pym/cache pym/elog_modules; do
+                       rm "${ROOT}"/${portage_base}/${mydir}/*.pyc >& /dev/null
+                       rm "${ROOT}"/${portage_base}/${mydir}/*.pyo >& /dev/null
+               done
+       fi
+}
+
+pkg_postinst() {
+       local x
+
+       if [ ! -f "${ROOT}/var/lib/portage/world" ] &&
+          [ -f "${ROOT}"/var/cache/edb/world ] &&
+          [ ! -h "${ROOT}"/var/cache/edb/world ]; then
+               mv "${ROOT}"/var/cache/edb/world "${ROOT}"/var/lib/portage/world
+               ln -s ../../lib/portage/world /var/cache/edb/world
+       fi
+
+       for x in "${ROOT}"/etc/._cfg????_make.globals; do
+               # Overwrite the globals file automatically.
+               [ -e "${x}" ] && mv -f "${x}" "${ROOT}etc/make.globals"
+       done
+
+       portage_docs
+}