dev-python/bleach-3.1.0-r1: revbump, add py38, distutils helper
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 4 Dec 2019 21:47:30 +0000 (13:47 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 4 Dec 2019 21:59:58 +0000 (13:59 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/bleach/bleach-3.1.0-r1.ebuild [moved from dev-python/bleach/bleach-3.1.0.ebuild with 65% similarity]

similarity index 65%
rename from dev-python/bleach/bleach-3.1.0.ebuild
rename to dev-python/bleach/bleach-3.1.0-r1.ebuild
index 386329537c313a1f6bbb93f1bec5700631b03401..51c292c42449cf7524c00bb5a8a68134bc942b2f 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
 
 inherit distutils-r1
 
@@ -17,11 +17,8 @@ IUSE="test"
 
 RDEPEND="
        dev-python/six[${PYTHON_USEDEP}]
-       dev-python/webencodings[${PYTHON_USEDEP}]"
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+       dev-python/webencodings[${PYTHON_USEDEP}]
+"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 
-python_test() {
-       pytest -v || die "tests failed under ${EPYTHON}"
-}
+distutils_enable_tests pytest