xfce-base/libxfce4ui: Bump to 4.13.7
authorMichał Górny <mgorny@gentoo.org>
Sun, 28 Jul 2019 15:19:41 +0000 (17:19 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 28 Jul 2019 15:43:15 +0000 (17:43 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-base/libxfce4ui/Manifest
xfce-base/libxfce4ui/libxfce4ui-4.13.7.ebuild [new file with mode: 0644]

index c61b61274780fd5d1951c043b2926d67503f7813..105f27d5d168432f14570329eff62f4cdc429aa8 100644 (file)
@@ -1,3 +1,4 @@
 DIST libxfce4ui-4.13.4.tar.bz2 684065 BLAKE2B 1da875832683b5e06b8e91b4078be8122ae85a91560d7b1768cb8c880fcf5e1d7cd07d24927ae3325ba9c500c6c2cd30e717e517775492b9948add0711f5aa40 SHA512 c82d6ff7ea0da4fc0f664bab92f1e9531162996a26bb092e6ba651cfc4551732cbcd8023908d428b47906c17c331c14bf4804256566ca564befa218dc1194206
 DIST libxfce4ui-4.13.5.tar.bz2 742371 BLAKE2B 1ddfed2f6b2c360e39a00c5bbe7c9e2a01595197e808531438eb8f84e8e13680c4fa8a29f0d1ba61be0726222d253921740e73f960fedd12c3ec8339c345ea81 SHA512 5ce49c7052392ac0df74b0d5069fa7880d7b322a15b10c5c20932f10ae06529be2b21d95f7e1c10a8ecb2e38cce9a2d880ac107c3ce1e7f51d570d5ece7b7d3c
 DIST libxfce4ui-4.13.6.tar.bz2 734078 BLAKE2B 18dab32e0d01066f21bcebefbf3c0e96a0c8209f78a7a0577a9592a632005d88f91c7f477f2ad5f5ca499699324a1cb95d9c23356b53d50923e025bd43f63549 SHA512 1992bf5d41fdc200281004f035542f6b5f225edad20e37c9c47fc531e94055473c3747be6026740f0ec32f5ff5f1a42072b624e71b326467711c724372dca8c4
+DIST libxfce4ui-4.13.7.tar.bz2 738592 BLAKE2B e59727f05d4772a164ed097ad8629a7327a8a6eafb99d78f3aab093879195b20d2e7f7192dbc3f1c8df67836b98695d274e64744dc57271bd87f9cd1e6e50adc SHA512 bcee0bd7b1f1200c195809b8484778326d02637c06754e876d0fdcdfb860ea642fc342c3fc5cb4b181bfbd58f17a695cc1fa1b318725f774f3b79e544ee4b32d
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.13.7.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.13.7.ebuild
new file mode 100644 (file)
index 0000000..e444536
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade introspection startup-notification vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42:2=
+       >=x11-libs/gtk+-2.24:2=
+       >=x11-libs/gtk+-3.18:3=[introspection?]
+       x11-libs/libX11:=
+       x11-libs/libICE:=
+       x11-libs/libSM:=
+       >=xfce-base/libxfce4util-4.12:=[introspection?]
+       >=xfce-base/xfconf-4.12:=
+       glade? ( dev-util/glade:3.10= )
+       introspection? ( dev-libs/gobject-introspection:= )
+       startup-notification? ( x11-libs/startup-notification:= )
+       !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+       dev-lang/perl
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig
+       vala? ( $(vala_depend) )"
+
+src_prepare() {
+       # stupid vala.eclass...
+       default
+}
+
+src_configure() {
+       local myconf=(
+               $(use_enable introspection)
+               $(use_enable startup-notification)
+               $(use_enable vala)
+               # TODO: check revdeps and make it optional one day
+               --enable-gtk2
+               # requires deprecated glade:3 (gladeui-1.0), bug #551296
+               --disable-gladeui
+               # this one's for :3.10
+               $(use_enable glade gladeui2)
+               --with-vendor-info=Gentoo
+       )
+
+       use vala && vala_src_prepare
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}