dev-libs/wayland: Drop old versions
authorMatt Turner <mattst88@gentoo.org>
Mon, 6 Apr 2020 20:01:29 +0000 (13:01 -0700)
committerMatt Turner <mattst88@gentoo.org>
Mon, 6 Apr 2020 20:14:49 +0000 (13:14 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-libs/wayland/Manifest
dev-libs/wayland/wayland-1.17.0.ebuild [deleted file]

index c8f8132d6d3f6340dcb6fc9c5be1ff157272ae6f..c2c407e3dfb6698e1bcc1683ada02ab39227a8af 100644 (file)
@@ -1,2 +1 @@
-DIST wayland-1.17.0.tar.xz 437680 BLAKE2B 2f4eb54c5ded90453b4e2812f7b5086aa211196ec9f7333d316cdb829269d55db570ccb45a67ee07a039633245e630ab54da6403ff4754d59366f3c13fb87549 SHA512 c5051aab5ff078b368c196ecfedb33ccd961265bb914845d7ed81de361bb86ae18299575baa6c4eceb0d82cf8b495e8293f31b51d1cbc05d84af0a199ab3f946
 DIST wayland-1.18.0.tar.xz 453968 BLAKE2B ee5b3f9dff07fda85b4d64bc753aff28c4a012184eb3a4bae8e3be0fb74324f12e9ea4e3dc049e06a11c7302e3c6b1e53e49109c814381641568d92b5572eed9 SHA512 e30199e30c2bbd361ee695b4f3f7a4e264f10ed8f46f2c90762b5739fc578ae757dc39aa0258d8fbf0ed418553470bccd4b2730ed9705481cfccdab5de96a8fc
diff --git a/dev-libs/wayland/wayland-1.17.0.ebuild b/dev-libs/wayland/wayland-1.17.0.ebuild
deleted file mode 100644 (file)
index 7b05ce9..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = *9999* ]]; then
-       EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
-       inherit git-r3
-else
-       SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
-       KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-fi
-inherit autotools libtool multilib-minimal toolchain-funcs
-
-DESCRIPTION="Wayland protocol libraries"
-HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc static-libs"
-
-BDEPEND="
-       virtual/pkgconfig
-       doc? (
-               >=app-doc/doxygen-1.6[dot]
-               app-text/xmlto
-               >=media-gfx/graphviz-2.26.0
-               sys-apps/grep[pcre]
-       )
-"
-DEPEND="
-       >=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
-       dev-libs/libxml2:=
-       >=virtual/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
-"
-RDEPEND="${DEPEND}
-       !<media-libs/mesa-18.1.1-r1
-"
-
-src_prepare() {
-       default
-       [[ $PV = 9999* ]] && eautoreconf || elibtoolize
-}
-
-multilib_src_configure() {
-       local myeconfargs=(
-               --disable-static
-               $(multilib_native_use_enable doc documentation)
-               $(multilib_native_enable dtd-validation)
-       )
-       tc-is-cross-compiler && myeconfargs+=( --with-host-scanner )
-
-       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install_all() {
-       find "${D}" -name '*.la' -delete || die
-       einstalldocs
-}
-
-src_test() {
-       # We set it on purpose to only a short subdir name, as socket paths are
-       # created in there, which are 108 byte limited. With this it hopefully
-       # barely fits to the limit with /var/tmp/portage/$CAT/$PF/temp/xdr
-       export XDG_RUNTIME_DIR="${T}"/xdr
-       mkdir "${XDG_RUNTIME_DIR}" || die
-       chmod 0700 "${XDG_RUNTIME_DIR}" || die
-
-       multilib-minimal_src_test
-}