kde-plasma/plasma-nm: Fix missing headers with Frameworks 5.62
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 15 Sep 2019 15:23:51 +0000 (17:23 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 15 Sep 2019 15:24:58 +0000 (17:24 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-plasma/plasma-nm/files/plasma-nm-5.16.5-missing-headers.patch [new file with mode: 0644]
kde-plasma/plasma-nm/plasma-nm-5.16.5.ebuild

diff --git a/kde-plasma/plasma-nm/files/plasma-nm-5.16.5-missing-headers.patch b/kde-plasma/plasma-nm/files/plasma-nm-5.16.5-missing-headers.patch
new file mode 100644 (file)
index 0000000..676087e
--- /dev/null
@@ -0,0 +1,62 @@
+From a7eb3cb599fbb1d66c6980d53550822cbbfd1520 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Wed, 14 Aug 2019 11:25:49 +0200
+Subject: Add missing headers with DISABLE_MODEMMANAGER_SUPPORT=ON
+
+Reviewers: jgrulich
+
+Reviewed By: jgrulich
+
+Subscribers: plasma-devel
+
+Tags: #plasma
+
+Differential Revision: https://phabricator.kde.org/D23148
+---
+ libs/declarative/networkstatus.cpp | 2 ++
+ libs/handler.cpp                   | 1 +
+ libs/handler.h                     | 1 +
+ 3 files changed, 4 insertions(+)
+
+diff --git a/libs/declarative/networkstatus.cpp b/libs/declarative/networkstatus.cpp
+index b9db376..e94b7ea 100644
+--- a/libs/declarative/networkstatus.cpp
++++ b/libs/declarative/networkstatus.cpp
+@@ -20,7 +20,9 @@
+ #include "networkstatus.h"
+ #include "uiutils.h"
++
+ #include <QDBusConnection>
++#include <QDBusConnectionInterface>
+ #include <NetworkManagerQt/ActiveConnection>
+ #include <NetworkManagerQt/Connection>
+diff --git a/libs/handler.cpp b/libs/handler.cpp
+index 40b4b43..0095aa7 100644
+--- a/libs/handler.cpp
++++ b/libs/handler.cpp
+@@ -46,6 +46,7 @@
+ #endif
+ #include <QDBusError>
++#include <QDBusMetaType>
+ #include <QDBusPendingReply>
+ #include <QIcon>
+diff --git a/libs/handler.h b/libs/handler.h
+index f8b7941..4c72699 100644
+--- a/libs/handler.h
++++ b/libs/handler.h
+@@ -22,6 +22,7 @@
+ #define PLASMA_NM_HANDLER_H
+ #include <QDBusInterface>
++#include <QTimer>
+ #include <NetworkManagerQt/Connection>
+ #include <NetworkManagerQt/Settings>
+-- 
+cgit v1.1
+
+
index 995f4b6b6b89260958490a3049bb9a9432b4c2c5..0a6f38e56d3c03a4f442ca5024e58547d4a3cc7c 100644 (file)
@@ -53,6 +53,8 @@ RDEPEND="${DEPEND}
        $(add_plasma_dep kde-cli-tools)
 "
 
+PATCHES=( "${FILESDIR}/${P}-missing-headers.patch" )
+
 src_configure() {
        local mycmakeargs=(
                -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)