app-emulation/virt-manager: Apply fix from bug 717886 to live ebuild
authorBrian Evans <grknight@gentoo.org>
Sun, 19 Apr 2020 01:05:38 +0000 (21:05 -0400)
committerBrian Evans <grknight@gentoo.org>
Sun, 19 Apr 2020 01:05:38 +0000 (21:05 -0400)
Non-maintainer commit

Bug: https://bugs.gentoo.org/717886
Signed-off-by: Brian Evans <grknight@gentoo.org>
app-emulation/virt-manager/virt-manager-9999.ebuild

index 5b01845daf0ab57c3501695e8da68dafaa533071..bba518fa336bb03d1591cf644170f613b335b332 100644 (file)
@@ -6,6 +6,7 @@ EAPI=6
 PYTHON_COMPAT=( python3_{6,7} )
 DISTUTILS_SINGLE_IMPL=1
 
+DISTUTILS_USE_SETUPTOOLS=no
 inherit gnome2 distutils-r1
 
 DESCRIPTION="A graphical tool for administering virtual machines"
@@ -60,9 +61,7 @@ src_prepare() {
        distutils-r1_src_prepare
 }
 
-distutils-r1_python_compile() {
-       local defgraphics=
-
+python_configure() {
        esetup.py configure \
                --default-graphics=spice
 }