app-editors/wxhexeditor: remove old
authorMart Raudsepp <leio@gentoo.org>
Sat, 6 Jan 2018 14:25:16 +0000 (16:25 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sat, 6 Jan 2018 14:33:20 +0000 (16:33 +0200)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-editors/wxhexeditor/Manifest
app-editors/wxhexeditor/files/wxhexeditor-0.23-syslibs.patch [deleted file]
app-editors/wxhexeditor/wxhexeditor-0.23.ebuild [deleted file]
app-editors/wxhexeditor/wxhexeditor-0.24.ebuild

index 2ed195788c7c20f7a321fe77b42972a58f09dd20..6599d4e7fbe0f2c90d8fc758e1638ac43412c49e 100644 (file)
@@ -1,2 +1 @@
-DIST wxHexEditor-v0.23-src.tar.bz2 2534659 BLAKE2B 932b2d9ab14dee71b5f5f57d89bc71c190c136c106339563ade44ea47e47819c4fdb32511296c14b3bebdfedd55a331c74e9a722e1d54e22ba53d203f753b57d SHA512 abbd2338c2d0d7d514342f5c330ea42c9ee1f3489c4661426927f51c802a7806e4ee965fa5d467c7b928ba87395eb6c351ab5f43f18d5fce836adede5f1d6be4
 DIST wxHexEditor-v0.24-src.tar.xz 900868 BLAKE2B 6748249d75e7570197a6c78378a8f3109bfa4c72bf32fe63e2abd31734d97fda3d56ecddb52ac5f9a18cc77b2c727f8277688f1bf75ef8f665a3a9cefd1cb8a6 SHA512 8589da169c90cca5abf6ba957d5c5e17e4211123dbdbaf0e04d31757113e7e302d40df58144ec25d431c7c4ce2fa2721b16621d03630ac8b90478c704a8c5b09
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.23-syslibs.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.23-syslibs.patch
deleted file mode 100644 (file)
index 341c63b..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-Use system copies of mhash and udis86.
-Also pass -fopenmp when linking to avoid build errors.
-
---- a/Makefile
-+++ b/Makefile
-@@ -3,9 +3,9 @@ WXCONFIG = wx-config
- #CXX ?= `$(WXCONFIG) --cxx`
- CC = `$(WXCONFIG) --cc`
- CXX = `$(WXCONFIG) --cxx`
--LDFLAGS += -lgomp
-+LDFLAGS += -fopenmp -lgomp
- #add this ldflags for WinConsole  "-Wl,--subsystem,console -mconsole" for win-debug
--WXCXXFLAGS= `$(WXCONFIG) --cxxflags` -Iudis86 -Imhash/include -MMD -fopenmp
-+WXCXXFLAGS= `$(WXCONFIG) --cxxflags` -MMD -fopenmp
- WXLDFLAGS = `$(WXCONFIG) --libs` `$(WXCONFIG) --libs aui` `$(WXCONFIG) --libs core`
- RC = `$(WXCONFIG) --rescomp`
- #RC = x86_64-w64-mingw32-windres --define WX_CPU_AMD64
-@@ -25,7 +25,7 @@ SOURCES= src/HexEditorGui.cpp \
-                       src/HexEditorCtrl/wxHexCtrl/Tag.cpp\
-                       src/HexEditorCtrl/HexEditorCtrlGui.cpp\
-                       src/HexEditorFrame.cpp
--LIBS = udis86/libudis86/.libs/libudis86.a mhash/lib/.libs/libmhash.a
-+LIBS = -ludis86 -lmhash
- OBJECTS=$(SOURCES:.cpp=.o)
- DEPENDS=$(OBJECTS:.o=.d)
- LANGUAGEDIRS=`ls -l ./locale | grep ^d | sed s/.*\ //g;`
-@@ -36,7 +36,7 @@ EXECUTABLE=wxHexEditor
- EXECUTABLE_WIN=$(EXECUTABLE).exe
- EXECUTABLE_DIR_MAC=$(EXECUTABLE).app
--PREFIX      = /usr/local
-+PREFIX      = /usr
- BINDIR      = $(PREFIX)/bin
- DATADIR     = $(PREFIX)/share
- LOCALEDIR   = $(DATADIR)/locale
-@@ -63,15 +63,6 @@ langs: $(MOBJECTS)
- %.mo : %.po
-       $(MSGFMT) $< -o $@
--udis86/libudis86/.libs/libudis86.a:
--      cd udis86;./autogen.sh
--      cd udis86;./configure --host=$(HOST) CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" CPPFLAGS="$(CPPFLAGS)"
--      cd udis86/libudis86; $(MAKE) $(MFLAGS)
--
--mhash/lib/.libs/libmhash.a:
--      cd mhash; ./configure --host=$(HOST) CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" CPPFLAGS="$(CPPFLAGS)"
--      cd mhash; $(MAKE) $(MFLAGS)
--
- win: $(RESOURCES) $(EXECUTABLE_WIN)
- #Stack override required for file comparison function...
---- a/src/HexDialogs.cpp
-+++ b/src/HexDialogs.cpp
-@@ -24,7 +24,7 @@
- #define NANINT 0xFFFFFFFFFFFFFFFFLL
- #include "HexDialogs.h"
- #include <wx/progdlg.h>
--#include "../mhash/include/mhash.h"
-+#include <mhash.h>
- #ifdef _OPENMP_
-    #include <omp.h>
---- a/src/HexEditor.h
-+++ b/src/HexEditor.h
-@@ -25,7 +25,7 @@
- #ifndef _wxHexEditor_h_
- #define _wxHexEditor_h_
--#include "../mhash/include/mhash.h"
-+#include <mhash.h>
- #include <wx/ffile.h>
- #include <wx/clipbrd.h>
---- a/src/HexPanels.h
-+++ b/src/HexPanels.h
-@@ -27,7 +27,7 @@
- #include "HexEditorFrame.h"
- #include "HexEditorCtrl/HexEditorCtrl.h"
- #include "HexEditorCtrl/wxHexCtrl/wxHexCtrl.h"
--#include "../udis86/udis86.h"
-+#include <udis86.h>
- #ifdef WX_GCH
- #include <wx_pch.h>
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.23.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.23.ebuild
deleted file mode 100644 (file)
index 21b7484..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PLOCALES="ar cs de es fr hu_HU it ja_JP nl_NL pl pt_BR ro ru tr zh_CN"
-
-inherit eutils l10n toolchain-funcs wxwidgets
-
-MY_PN="wxHexEditor"
-
-DESCRIPTION="A cross-platform hex editor designed specially for large files"
-HOMEPAGE="http://wxhexeditor.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-v${PV}-src.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
-       app-crypt/mhash
-       dev-libs/udis86
-       x11-libs/wxGTK:3.0[X]"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_PN}"
-
-pkg_pretend() {
-       tc-has-openmp \
-               || die "${PN} uses OpenMP libraries. Please use an OpenMP-capable compiler."
-}
-
-src_prepare() {
-       WX_GTK_VER="3.0" need-wxwidgets unicode
-       epatch "${FILESDIR}"/${P}-syslibs.patch
-
-       do_kill_locale() {
-               rm -r "${S}"/locale/${1}
-       }
-
-       rm "${S}"/locale/wxHexEditor.pot
-       l10n_find_plocales_changes "${S}"/locale '' ''
-       l10n_for_each_disabled_locale_do do_kill_locale
-}
index dbdf1906fe82ea6c7fb0e6f571f8b885efde53ad..517f24a35eb8e46c8093174e49d2188fdb574b9a 100644 (file)
@@ -30,11 +30,11 @@ PATCHES=(
 )
 
 pkg_pretend() {
-        [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+       [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
 }
 
 pkg_setup() {
-        [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
+       [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
 }
 
 src_prepare() {