app-text/openjade: fix compilation using Clang, bug #604534
authorFabian Groffen <grobian@gentoo.org>
Thu, 12 Jan 2017 19:57:45 +0000 (20:57 +0100)
committerFabian Groffen <grobian@gentoo.org>
Thu, 12 Jan 2017 19:57:45 +0000 (20:57 +0100)
Package-Manager: portage-2.3.0

app-text/openjade/openjade-1.3.2-r6.ebuild

index 0bb418f7b93d1711ff1c5d83f86adfeac8656204..2e968d49858e4b8306e840e77cdf793538e52069 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
 
-inherit autotools sgml-catalog eutils flag-o-matic multilib
+inherit autotools sgml-catalog eutils flag-o-matic multilib toolchain-funcs
 
 DESCRIPTION="Jade is an implementation of DSSSL for formatting SGML and XML documents"
 HOMEPAGE="http://openjade.sourceforge.net"
@@ -53,7 +53,7 @@ src_configure() {
        # avoids dead-store elimination optimization
        # leading to segfaults on GCC 6
        # bug #592590 #596506
-       append-cxxflags $(test-flags-CXX -fno-lifetime-dse)
+       tc-is-clang || append-cxxflags $(test-flags-CXX -fno-lifetime-dse)
 
        # We need Prefix env, bug #287358
        export CONFIG_SHELL="${CONFIG_SHELL:-${BASH}}"