dev-python/jsonpickle-1.4.1-r1: revbump, remove pandas test dep, py38
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 29 Apr 2020 06:28:58 +0000 (23:28 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 29 Apr 2020 06:31:02 +0000 (23:31 -0700)
Since the dependency on pandas is only a test dep, and is only needs for
3 out of more than 320 tests, let's just patch it out so we don't have
to drop keywords and we can add python3_8.

Closes: https://bugs.gentoo.org/719980
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/jsonpickle/jsonpickle-1.4.1-r1.ebuild [moved from dev-python/jsonpickle/jsonpickle-1.4.1.ebuild with 79% similarity]

similarity index 79%
rename from dev-python/jsonpickle/jsonpickle-1.4.1.ebuild
rename to dev-python/jsonpickle/jsonpickle-1.4.1-r1.ebuild
index d097093c8648178010c9b190fc60982d841a445b..f9b5040f15688729d8d66973fad0095e1e9d4006 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 DISTUTILS_USE_SETUPTOOLS=rdepend
 inherit distutils-r1
 
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
 IUSE="doc test"
 RESTRICT="!test? ( test )"
 
@@ -24,14 +24,17 @@ RDEPEND="
        dev-python/feedparser[${PYTHON_USEDEP}]
        dev-python/ujson[${PYTHON_USEDEP}]
 "
-DEPEND="
-       test? ( ${RDEPEND}
-               dev-python/pandas[${PYTHON_USEDEP}]
-       )
-"
 
 distutils_enable_sphinx "docs/source"
 
+python_prepare_all() {
+       # too many dependencies
+       rm tests/pandas_test.py || die
+       sed -e '/pandas/ d' -i tests/runtests.py || die
+
+       distutils-r1_python_prepare_all
+}
+
 python_test() {
        # An apparent regression in tests
        # https://github.com/jsonpickle/jsonpickle/issues/124