dev-php/pecl-raphf: add PHP 7.4 support
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 28 Nov 2019 22:21:37 +0000 (23:21 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 28 Nov 2019 22:47:52 +0000 (23:47 +0100)
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-php/pecl-raphf/pecl-raphf-2.0.1.ebuild

index f28c7a6bb551f8b95b2183483b556a7c388a9ae8..9923b1d0c97d5231784309ef924cbfdbd1216945 100644 (file)
@@ -9,12 +9,12 @@ PHP_EXT_ZENDEXT="no"
 PHP_EXT_ECONF_ARGS=""
 PHP_INI_NAME="30-${PHP_EXT_NAME}"
 
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3 php7-4"
 
 inherit php-ext-pecl-r3
 
 # Only really build for 7.x
-USE_PHP="php7-1 php7-2 php7-3"
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
 
 KEYWORDS="~amd64 ~x86"
 
@@ -26,7 +26,7 @@ IUSE=""
 RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
 
 src_prepare() {
-       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
+       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4; then
                php-ext-source-r3_src_prepare
        else
                default_src_prepare
@@ -34,7 +34,7 @@ src_prepare() {
 }
 
 src_install() {
-       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3; then
+       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4; then
                php-ext-pecl-r3_src_install
        fi
 }