dev-util/cligh: Bump to 0.3, py3.7
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 11:46:57 +0000 (12:46 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 11:59:48 +0000 (12:59 +0100)
Closes: https://bugs.gentoo.org/708308
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/cligh/Manifest
dev-util/cligh/cligh-0.3.ebuild [new file with mode: 0644]
dev-util/cligh/cligh-9999.ebuild

index 8ee31d03a0bc27b321c855e72edc376a44296bfb..9454f268e395fa67f4c198f64e6069c62911fb1d 100644 (file)
@@ -1,2 +1,3 @@
 DIST cligh-0.1_p20120630.tar.gz 7848 BLAKE2B 4690330e4b353244bc1e7065759637fa9d1de0b412357f00ebbc432e88b6fb00718ba1177900e3bad77c0a0ce8bb3b0defe3de1004137c3ebe73d9d255739291 SHA512 1be944a18cad117ddceb5461f0f53c083f34afe32c79d5ce9494c587fa5d8b8f7c7acc3f7447e18677b7fce2fa96ed7bb34a228b5528f19fe4933a24fefa933d
 DIST cligh-0.2.tar.gz 7844 BLAKE2B 001e597ee60fd8b9e378c96f1ad4ab9dcf42de049bc2a914f8dece12048beebe0ec04b095cad64508af611b2fe52ca43fcf62b5bded74b3336359be85fef1235 SHA512 9b6e5e187324ccc1d9264aa259f648231f46aa443b75682206a17626f4f6f594a14538066f5e561c8a296d740506216db4cbd6ef7a9d25338a9d641cec7e3b9c
+DIST cligh-0.3.tar.gz 8043 BLAKE2B 496c7d169463a2ecec66ac193480503eb4f5207c8e874fedd8a8a50047f5a3e480dc3c8f7cd401e1c1360a9fa1ae918adfd4f2e5ba928f8ff68df8032d8360af SHA512 85aa702c15e6f19b0118c642944d3151648f38d8f9e86a93f4d4c03c28245548e9910d21edc19f3ada338c33b995fee7bb03e6bafd99499d58cdba35b37faca8
diff --git a/dev-util/cligh/cligh-0.3.ebuild b/dev-util/cligh/cligh-0.3.ebuild
new file mode 100644 (file)
index 0000000..e5589bd
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command-line interface to GitHub"
+HOMEPAGE="https://the-brannons.com/software/cligh.html"
+SRC_URI="https://the-brannons.com/software/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/PyGithub[${PYTHON_USEDEP}]
+       dev-python/pyxdg[${PYTHON_USEDEP}]"
index 808fce4ea2dd8cb579414b2e5d5ac1f11623fad8..186acb99add142c102424995adc254d50dd4c19a 100644 (file)
@@ -1,20 +1,20 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7} )
 
 inherit distutils-r1 git-r3
 
 DESCRIPTION="Command-line interface to GitHub"
-HOMEPAGE="http://the-brannons.com/software/cligh.html"
+HOMEPAGE="https://the-brannons.com/software/cligh.html"
 EGIT_REPO_URI="https://github.com/CMB/${PN}.git"
 
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS=""
-IUSE=""
 
-DEPEND="dev-python/PyGithub[${PYTHON_USEDEP}]
+RDEPEND="dev-python/PyGithub[${PYTHON_USEDEP}]
        dev-python/pyxdg[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"