dev-python/reflink: correct dep on pytest-runner
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 29 Jan 2019 17:50:53 +0000 (09:50 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 29 Jan 2019 17:51:54 +0000 (09:51 -0800)
Closes: https://bugs.gentoo.org/676848
Package-Manager: Portage-2.3.59, Repoman-2.3.12
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-python/reflink/files/0.2.1-correct-test-deps.patch [new file with mode: 0644]
dev-python/reflink/reflink-0.2.1.ebuild

diff --git a/dev-python/reflink/files/0.2.1-correct-test-deps.patch b/dev-python/reflink/files/0.2.1-correct-test-deps.patch
new file mode 100644 (file)
index 0000000..78b1ef8
--- /dev/null
@@ -0,0 +1,17 @@
+diff --git a/setup.py b/setup.py
+index 234c92b..3ef3237 100644
+--- a/setup.py
++++ b/setup.py
+@@ -20,11 +20,11 @@ requirements = [
+ setup_requirements = [
+     'cffi',
+-    'pytest-runner',
+ ]
+ test_requirements = [
+     'pytest',
++    'pytest-runner',
+ ]
+ if sys.platform not in ['linux', 'linux2', 'win32', 'darwin']:
index 8c8c593ccf5238e4a551619207006b51f67b8377..59c051cb19490695d7495c2bc7a0f26c6c6e8c18 100644 (file)
@@ -30,6 +30,8 @@ DEPEND="${RDEPEND}"
 # goes places, like writing to /dev or creating btrfs volumes
 RESTRICT="test"
 
+PATCHES=( "${FILESDIR}/${PV}-correct-test-deps.patch" )
+
 python_compile_all() {
        use doc && emake -C docs html
 }