net-misc/chrony: Fix paths to config file
authorSam James (sam_c) <sam@cmpct.info>
Sun, 19 Apr 2020 20:54:06 +0000 (20:54 +0000)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 2 May 2020 10:43:27 +0000 (12:43 +0200)
OpenRC only; systemd unaffected by issue.
New "capsified" versions will use new config file, current stable
chrony now has a fixed file.

Revbump is complicated here given -r3, ..., already exists.
This should not have affected many users so this seems like
the simplest solution.

Closes: https://bugs.gentoo.org/719876
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
net-misc/chrony/chrony-3.5-r4.ebuild
net-misc/chrony/chrony-4.0_pre1-r2.ebuild
net-misc/chrony/chrony-4.0_pre2-r1.ebuild
net-misc/chrony/chrony-9999.ebuild
net-misc/chrony/files/chronyd.conf
net-misc/chrony/files/chronyd.conf-r1 [new file with mode: 0644]

index ae752af2fb58ff8c5e5fb5675b365caa88ce0cdd..a7a99b957db450836d6ce9825c20413594b49d99 100644 (file)
@@ -51,7 +51,7 @@ src_prepare() {
                doc/* examples/* || die
 
        # Copy for potential user fixup
-       cp "${FILESDIR}"/chronyd.conf "${T}"/chronyd.conf
+       cp "${FILESDIR}"/chronyd.conf-r1 "${T}"/chronyd.conf
        cp examples/chronyd.service "${T}"/chronyd.service
 
        # Set config for privdrop
index c4c8a13c29a9c996cb7f8d2977e6c2040b37db65..7cc61849d3d5dfcbe437df574dbcbd8d48d2738b 100644 (file)
@@ -53,7 +53,7 @@ src_prepare() {
                doc/* examples/* || die
 
        # Copy for potential user fixup
-       cp "${FILESDIR}"/chronyd.conf "${T}"/chronyd.conf
+       cp "${FILESDIR}"/chronyd.conf-r1 "${T}"/chronyd.conf
        cp examples/chronyd.service "${T}"/chronyd.service
 
        # Set config for privdrop
index 07017bb6772c0f35e4235a45aa98362792edc741..503840b27548425b1077cbf190828c95570c7348 100644 (file)
@@ -53,7 +53,7 @@ src_prepare() {
                doc/* examples/* || die
 
        # Copy for potential user fixup
-       cp "${FILESDIR}"/chronyd.conf "${T}"/chronyd.conf
+       cp "${FILESDIR}"/chronyd.conf-r1 "${T}"/chronyd.conf
        cp examples/chronyd.service "${T}"/chronyd.service
 
        # Set config for privdrop
index 543cabf61d5c384738777c1f637e12dbc202ae88..8d8758fa5c60d3129d9abcfd06a31d8ca3556e3d 100644 (file)
@@ -50,7 +50,7 @@ src_prepare() {
                doc/* examples/* || die
 
        # Copy for potential user fixup
-       cp "${FILESDIR}"/chronyd.conf "${T}"/chronyd.conf
+       cp "${FILESDIR}"/chronyd.conf-r1 "${T}"/chronyd.conf
        cp examples/chronyd.service "${T}"/chronyd.service
 
        # Set config for privdrop
index c04f3525f0b7cd29490e5bd38ec3f703844c672c..fc43a95c40fed57b1310e2478aa65ae15f808bfb 100644 (file)
@@ -9,4 +9,4 @@ CFGFILE="/etc/chrony/chrony.conf"
 # The combination of "-s -r" allows chronyd to perform long term averaging of
 # the gain or loss rate across system reboots and shutdowns.
 
-ARGS="-u ntp -F 1"
+ARGS=""
diff --git a/net-misc/chrony/files/chronyd.conf-r1 b/net-misc/chrony/files/chronyd.conf-r1
new file mode 100644 (file)
index 0000000..c04f352
--- /dev/null
@@ -0,0 +1,12 @@
+# /etc/conf.d/chronyd
+
+CFGFILE="/etc/chrony/chrony.conf"
+
+# Configuration dependant options :
+#      -s - Set system time from RTC if rtcfile directive present
+#      -r - Reload sample histories if dumponexit directive present
+#
+# The combination of "-s -r" allows chronyd to perform long term averaging of
+# the gain or loss rate across system reboots and shutdowns.
+
+ARGS="-u ntp -F 1"