media-sound/tuxguitar: fdo-mime->xdg-utils, eutils->desktop, HOMEPAGE
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 10 Jun 2019 20:28:55 +0000 (22:28 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 10 Jun 2019 20:34:14 +0000 (22:34 +0200)
Add missing media-sound/fluidsynth slot op

Minur tidy-up:
no ${PN} in DESCRIPTION
CDEPEND -> COMMON_DEPEND
Sort DEPENDs

Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-sound/tuxguitar/tuxguitar-1.3.2.ebuild

index 61ca5827d67c18874cb6634655b0c0a56d232614..7c0a2bf1b65cad664ea36dc57766d13e609f973e 100644 (file)
@@ -1,39 +1,40 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="6"
-JAVA_PKG_IUSE="source"
-
-inherit eutils java-pkg-2 java-ant-2 toolchain-funcs flag-o-matic fdo-mime gnome2-utils
+EAPI=6
 
 MY_P="${P}-src"
-DESCRIPTION="TuxGuitar is a multitrack guitar tablature editor and player written in Java-SWT"
-HOMEPAGE="http://tuxguitar.herac.com.ar/"
+JAVA_PKG_IUSE="source"
+inherit desktop java-pkg-2 java-ant-2 toolchain-funcs flag-o-matic xdg-utils
+
+DESCRIPTION="Multitrack guitar tablature editor and player written in Java-SWT"
+HOMEPAGE="http://www.tuxguitar.com.ar/"
 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
 LICENSE="LGPL-2.1"
 SLOT="0"
-
 IUSE="alsa fluidsynth jack lilypond oss pdf timidity tray"
-
 KEYWORDS="~amd64 ~x86"
 
-CDEPEND="dev-java/swt:3.7[cairo]
+COMMON_DEPEND="
+       dev-java/swt:3.7[cairo]
        alsa? ( media-libs/alsa-lib )
        pdf? ( dev-java/itext:5 )
-       fluidsynth? ( media-sound/fluidsynth )
-       lilypond? ( media-sound/lilypond )"
-
-RDEPEND=">=virtual/jre-1.5
+       fluidsynth? ( media-sound/fluidsynth:= )
+       lilypond? ( media-sound/lilypond )
+"
+RDEPEND="${COMMON_DEPEND}
+       >=virtual/jre-1.5
        timidity? ( media-sound/timidity++[alsa?,oss?] )
-       ${CDEPEND}"
+"
+DEPEND="${COMMON_DEPEND}
+       >=virtual/jdk-1.5
+"
 
-DEPEND=">=virtual/jdk-1.5
-       ${CDEPEND}"
+PATCHES=( "${FILESDIR}"/${PN}-fixed-ant-files.patch )
 
 S="${WORKDIR}/${MY_P}"
 
-PATCHES=( "${FILESDIR}"/${PN}-fixed-ant-files.patch )
-
 LIBRARY_LIST=()
 PLUGIN_LIST=()
 
@@ -116,8 +117,8 @@ src_install() {
 }
 
 pkg_postinst() {
-       fdo-mime_desktop_database_update
-       gnome2_icon_cache_update
+       xdg_desktop_database_update
+       xdg_icon_cache_update
        if use fluidsynth; then
                ewarn "Fluidsynth plugin blocks behavior of JSA plugin."
                ewarn "Enable only one of them in \"Tools > Plugins\""
@@ -125,6 +126,6 @@ pkg_postinst() {
 }
 
 pkg_postrm() {
-       fdo-mime_desktop_database_update
-       gnome2_icon_cache_update
+       xdg_desktop_database_update
+       xdg_icon_cache_update
 }