dev-python/webtest: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 12:32:47 +0000 (14:32 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 12:32:47 +0000 (14:32 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/webtest/Manifest
dev-python/webtest/webtest-2.0.21.ebuild [deleted file]
dev-python/webtest/webtest-2.0.29-r1.ebuild [deleted file]
dev-python/webtest/webtest-2.0.29.ebuild [deleted file]

index 4ac12673163bffd8e7942a5358b269065d7cec44..b463cc828c888eeb9ed21e666efb24e4377d58ea 100644 (file)
@@ -1,3 +1 @@
-DIST WebTest-2.0.21.tar.gz 66866 BLAKE2B d2830fcce7fb4b91029838806952e3e9c6916c3b292c7142138f30486d936b4a1f0c2d28a5973b0c351c64e499f343f3711296c6e37c38548e3a81b108163a17 SHA512 21f58ee9192fd0eb0eb2d88179ffc015aa5cf04c8004db251bd65d13d54c34b9e6b5fc9fdd8e9fcbbc18fcfb2be714c0691b2ef034318861262f8705b4a44610
-DIST WebTest-2.0.29.tar.gz 74620 BLAKE2B 7fc68f1178b1abb0a0f126112b846853762ad78cb060718bc340f5ba17517180b7283f384503ff77a2c7396645ebe2d5528dbc0f027c5d44beb002c4204bf894 SHA512 319700d1444f6a681f8ed8a4ee8661ba0462b3f4bfeb7510232f58be92e017066da3bac494ebe1a3c5b9f2d06c025e08e6193277e13c6113e9485108d4ccd2d2
 DIST WebTest-2.0.33.tar.gz 76081 BLAKE2B 6c06d7cf6573282342ac190fe2365d041679fd9a75571a525cf0214f22a0631d5f97e94261090d9c2a372f77b005d22be5976f612c27c6b4c832c71469b33ee8 SHA512 9f5c614f8215837dc5cecc9c3e844c5e1678eb8275f9e27a0ec6a68648e9f4f09155aa72f6c731c34028b8671b7776a94235f3e54d7dbf5ff55de94840171ca8
diff --git a/dev-python/webtest/webtest-2.0.21.ebuild b/dev-python/webtest/webtest-2.0.21.ebuild
deleted file mode 100644 (file)
index 073cd5c..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-MY_PN="WebTest"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Helper to test WSGI applications"
-HOMEPAGE="https://pypi.org/project/WebTest/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc64 ~s390 sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-# nose<1.3.0 appears a leftover never updated in requires.txt. tests pass fine with latest
-RDEPEND="
-       dev-python/six[${PYTHON_USEDEP}]
-       >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
-       >=dev-python/webob-1.2[${PYTHON_USEDEP}]
-       dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
-       dev-python/lxml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       app-arch/unzip
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/pyquery[${PYTHON_USEDEP}]
-               dev-python/pastedeploy[${PYTHON_USEDEP}]
-               dev-python/wsgiproxy2[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 )
-       )"
-
-S="${WORKDIR}/${MY_P}"
-
-# Makes testing easier; otherwise we get errors from pkg_resources.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
-       # Prevent un-needed d'loading during doc build
-       sed -s 's:intersphinx_mapping:_&:' -i docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build docs html || die
-       fi
-}
-
-python_test() {
-       # Tests raise ImportErrors with our default PYTHONPATH.
-       local -x PYTHONPATH=
-       nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/webtest/webtest-2.0.29-r1.ebuild b/dev-python/webtest/webtest-2.0.29-r1.ebuild
deleted file mode 100644 (file)
index 0849379..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="WebTest"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Helper to test WSGI applications"
-HOMEPAGE="https://pypi.org/project/WebTest/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-# nose<1.3.0 appears a leftover never updated in requires.txt. tests pass fine with latest
-RDEPEND="
-       dev-python/six[${PYTHON_USEDEP}]
-       >=dev-python/webob-1.2[${PYTHON_USEDEP}]
-       >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
-       dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       app-arch/unzip
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/pyquery[${PYTHON_USEDEP}]
-               dev-python/pastedeploy[${PYTHON_USEDEP}]
-               dev-python/wsgiproxy2[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 )
-       )"
-
-S="${WORKDIR}/${MY_P}"
-
-# Makes testing easier; otherwise we get errors from pkg_resources.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
-       # Prevent un-needed d'loading during doc build
-       sed -s 's:intersphinx_mapping:_&:' -i docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build docs html || die
-       fi
-}
-
-python_test() {
-       # Tests raise ImportErrors with our default PYTHONPATH.
-       local -x PYTHONPATH=
-       nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/webtest/webtest-2.0.29.ebuild b/dev-python/webtest/webtest-2.0.29.ebuild
deleted file mode 100644 (file)
index cfa410f..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-MY_PN="WebTest"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Helper to test WSGI applications"
-HOMEPAGE="https://pypi.org/project/WebTest/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc64 s390 sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-# nose<1.3.0 appears a leftover never updated in requires.txt. tests pass fine with latest
-RDEPEND="
-       dev-python/six[${PYTHON_USEDEP}]
-       >=dev-python/webob-1.2[${PYTHON_USEDEP}]
-       >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
-       dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       app-arch/unzip
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/pyquery[${PYTHON_USEDEP}]
-               dev-python/pastedeploy[${PYTHON_USEDEP}]
-               dev-python/wsgiproxy2[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 )
-       )"
-
-S="${WORKDIR}/${MY_P}"
-
-# Makes testing easier; otherwise we get errors from pkg_resources.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
-       # Prevent un-needed d'loading during doc build
-       sed -s 's:intersphinx_mapping:_&:' -i docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build docs html || die
-       fi
-}
-
-python_test() {
-       # Tests raise ImportErrors with our default PYTHONPATH.
-       local -x PYTHONPATH=
-       nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( html/. )
-       distutils-r1_python_install_all
-}