Revert "dev-python/pyzmq: Remove py2"
authorRick Farina <zerochaos@gentoo.org>
Tue, 25 Feb 2020 18:39:45 +0000 (13:39 -0500)
committerRick Farina <zerochaos@gentoo.org>
Tue, 25 Feb 2020 18:43:25 +0000 (13:43 -0500)
This reverts commit 3635fb57325467c27cf380249690345080c0b082.
Needed by net-wireless/urh and probably net-wireless/gnuradio
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
dev-python/pyzmq/pyzmq-16.0.2.ebuild
dev-python/pyzmq/pyzmq-17.1.0.ebuild

index c6f982a73c2647f6b8600ad324b93b064daa2df3..914737e0cb2b70a5ab9ca5cef03552e5911d0c7b 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
 PYTHON_REQ_USE="threads(+)"
 
 inherit flag-o-matic distutils-r1 toolchain-funcs
@@ -22,11 +22,13 @@ RDEPEND="
        >=net-libs/zeromq-4.1.2:=
        dev-python/py[${PYTHON_USEDEP}]
        dev-python/cffi:=[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
 "
 DEPEND="${RDEPEND}
        dev-python/cython[${PYTHON_USEDEP}]
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
                www-servers/tornado[${PYTHON_USEDEP}]
        )
        doc? (
@@ -51,6 +53,7 @@ python_compile_all() {
 
 python_compile() {
        esetup.py cython --force
+       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
        distutils-r1_python_compile
 }
 
index e7d8b211d8069a952e541c4f9bc1891be4e66e97..90216948f4ff7562d5d861d9ac8577e560174a6f 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
 PYTHON_REQ_USE="threads(+)"
 
 inherit flag-o-matic distutils-r1 toolchain-funcs
@@ -22,11 +22,13 @@ RDEPEND="
        >=net-libs/zeromq-4.2.2-r2:=[drafts]
        dev-python/py[${PYTHON_USEDEP}]
        dev-python/cffi:=[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
 "
 DEPEND="${RDEPEND}
        dev-python/cython[${PYTHON_USEDEP}]
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
                >=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
        )
        doc? (
@@ -53,6 +55,7 @@ python_compile_all() {
 
 python_compile() {
        esetup.py cython --force
+       python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
        distutils-r1_python_compile
 }