sys-libs/compiler-rt-sanitizers: Disable building CRT
authorMichał Górny <mgorny@gentoo.org>
Tue, 7 May 2019 13:40:06 +0000 (15:40 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 7 May 2019 13:40:06 +0000 (15:40 +0200)
Disable building CRT -- let sys-libs/compiler-rt install it.  This
should solve file collisions between the two packages.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild

index 2247b480c7d939f346df1da988bf675a900204c8..61271f31abe47fe17f123961fdeca4a37f10db73 100644 (file)
@@ -103,8 +103,9 @@ src_configure() {
                -DCOMPILER_RT_OUTPUT_DIR="${BUILD_DIR}/lib/clang/${SLOT}"
 
                -DCOMPILER_RT_INCLUDE_TESTS=$(usex test)
-               # built-ins installed by sys-libs/compiler-rt
+               # builtins & crt installed by sys-libs/compiler-rt
                -DCOMPILER_RT_BUILD_BUILTINS=OFF
+               -DCOMPILER_RT_BUILD_CRT=OFF
                -DCOMPILER_RT_BUILD_LIBFUZZER=$(usex libfuzzer)
                -DCOMPILER_RT_BUILD_PROFILE=$(usex profile)
                -DCOMPILER_RT_BUILD_SANITIZERS=$(usex sanitize)