Fix building in some locales #131462 by Andres Toomsalu.
authorMike Frysinger <vapier@gentoo.org>
Sat, 11 Nov 2006 09:18:55 +0000 (09:18 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 11 Nov 2006 09:18:55 +0000 (09:18 +0000)
Package-Manager: portage-2.1.2_rc1-r5

sys-libs/com_err/ChangeLog
sys-libs/com_err/com_err-1.39.ebuild
sys-libs/com_err/files/com_err-1.38-locale.patch [new file with mode: 0644]

index 45cd2015eb198c378599743c9c7fed85ea6342e0..2a04f18f99af6003e51ea817efb2cdc501dda95b 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for sys-libs/com_err
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/ChangeLog,v 1.25 2006/10/09 21:12:56 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/ChangeLog,v 1.26 2006/11/11 09:18:55 vapier Exp $
+
+  11 Nov 2006; Mike Frysinger <vapier@gentoo.org>
+  +files/com_err-1.38-locale.patch, com_err-1.39.ebuild:
+  Fix building in some locales #131462 by Andres Toomsalu.
 
   09 Oct 2006; Timothy Redaelli <drizzt@gentoo.org> com_err-1.39.ebuild:
   Added ~x86-fbsd keyword.
index 83864de2b4a848d381595e17ab5feb020a9576a5..c2208b14467ddbb4e483bc5f8e8e3652c936749a 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/com_err-1.39.ebuild,v 1.4 2006/10/09 21:12:56 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/com_err-1.39.ebuild,v 1.5 2006/11/11 09:18:55 vapier Exp $
 
 inherit eutils flag-o-matic toolchain-funcs
 
@@ -23,6 +23,7 @@ src_unpack() {
        cd "${S}"
        epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
        epatch "${FILESDIR}"/${PN}-1.39-parse-types.patch
+       epatch "${FILESDIR}"/${PN}-1.38-locale.patch
 }
 
 src_compile() {
diff --git a/sys-libs/com_err/files/com_err-1.38-locale.patch b/sys-libs/com_err/files/com_err-1.38-locale.patch
new file mode 100644 (file)
index 0000000..2a0919c
--- /dev/null
@@ -0,0 +1,30 @@
+Fix issues with non-C locales (like ee)
+
+http://bugs.gentoo.org/104116
+http://bugs.gentoo.org/131462
+
+--- e2fsprogs/lib/et/compile_et.sh.in
++++ e2fsprogs/lib/et/compile_et.sh.in
+@@ -1,6 +1,10 @@
+ #!/bin/sh
+ #
+ #
++
++# the awk scripts here use a-z and such
++export LC_ALL="C"
++
+ AWK=@AWK@
+ DIR="${DIR-@datadir@/et}"
+ ET_DIR="@ET_DIR@"
+--- e2fsprogs/lib/ss/mk_cmds.sh.in
++++ e2fsprogs/lib/ss/mk_cmds.sh.in
+@@ -2,6 +2,9 @@
+ #
+ #
++# the awk/sed scripts here use a-z and such
++export LC_ALL="C"
++
+ DIR="${DIR-@datadir@/ss}"
+ SS_DIR="@SS_DIR@"
+ AWK=@AWK@