dev-python/grpcio-testing: bump to 1.28.1
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 20 Apr 2020 06:30:19 +0000 (23:30 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 20 Apr 2020 07:25:34 +0000 (00:25 -0700)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-python/grpcio-testing/Manifest
dev-python/grpcio-testing/grpcio-testing-1.28.1.ebuild [new file with mode: 0644]

index 95cf6fc728d2b3326d0edffd4b2e1bad73f217c7..bad133feb31d744a49be4e2eef307ff8c8eb8c91 100644 (file)
@@ -1 +1,2 @@
 DIST grpcio-testing-1.26.0.tar.gz 17018 BLAKE2B 5747cef7d45ebd5deb0f86537fde2994ec7d4b0eb94cfbbfd3f9ad869e43a549d7a289477f76fc87d0c72a3a232bb643aa64c97e2ce3cc80ccb18368b276befb SHA512 7fae8c2e5dce79562005ae0c5e779e8ff157e245d849b573376aa36cc98fc6efa126f2aeed9431d2c41535ffbbac017ce69d83b5fffaf7f75b5493e778e8caf9
+DIST grpcio-testing-1.28.1.tar.gz 17127 BLAKE2B 494e232d4a4cf098cefa0948868f0610732d1aeb7c788d1481ad2693394767d73a74bfda49cb8c892f6f246f47b18c016318b5eefe3509fdc87be5649c253a17 SHA512 89c3aa5528e1f243a435997266a210ba6e287bca1401931689eb51f258a51768eb25a34c095d383dfcac7d446865535c48aefa0e37b4844bbb92214c7f431068
diff --git a/dev-python/grpcio-testing/grpcio-testing-1.28.1.ebuild b/dev-python/grpcio-testing/grpcio-testing-1.28.1.ebuild
new file mode 100644 (file)
index 0000000..4ac3f66
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Testing utilities for gRPC Python"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
+       dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"