dev-util/codeblocks: Revert "Support wxGTK:3.0" (Bug #575716)
authorRyan Hill <rhill@gentoo.org>
Sat, 27 Feb 2016 02:46:12 +0000 (20:46 -0600)
committerRyan Hill <rhill@gentoo.org>
Sat, 27 Feb 2016 02:46:12 +0000 (20:46 -0600)
Package-Manager: portage-2.2.27
Signed-off-by: Ryan Hill <rhill@gentoo.org>
dev-util/codeblocks/codeblocks-13.12-r1.ebuild [deleted file]
dev-util/codeblocks/codeblocks-9999.ebuild

diff --git a/dev-util/codeblocks/codeblocks-13.12-r1.ebuild b/dev-util/codeblocks/codeblocks-13.12-r1.ebuild
deleted file mode 100644 (file)
index fa0a728..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-WX_GTK_VER="3.0"
-
-inherit eutils wxwidgets
-
-DESCRIPTION="The open source, cross platform, free C++ IDE"
-HOMEPAGE="http://www.codeblocks.org/"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
-SRC_URI="mirror://sourceforge/codeblocks/${P/-/_}-1.tar.gz"
-
-IUSE="contrib debug pch static-libs"
-
-RDEPEND="app-arch/zip
-       x11-libs/wxGTK:${WX_GTK_VER}[X]
-       contrib? (
-               app-text/hunspell
-               dev-libs/boost:=
-               dev-libs/libgamin
-       )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-
-src_configure() {
-       need-wxwidgets unicode
-       econf \
-               --with-wx-config="${WX_CONFIG}" \
-               $(use_enable debug) \
-               $(use_enable pch) \
-               $(use_enable static-libs static) \
-               $(use_with contrib contrib-plugins all)
-}
-
-src_install() {
-       default
-       prune_libtool_files
-}
index d103c986e13c0e2a64c629eb5908564d396c59bd..6504279fb3524ec4f22f4d79ad139b575c105553 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI="5"
-WX_GTK_VER="3.0"
+WX_GTK_VER="2.8"
 
 inherit autotools eutils subversion wxwidgets