dev-lang/R: remove unused patches
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Sun, 9 Jun 2019 19:08:46 +0000 (21:08 +0200)
committerAaron Bauman <bman@gentoo.org>
Tue, 18 Jun 2019 00:34:54 +0000 (20:34 -0400)
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12229
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-lang/R/files/R-2.11.1-parallel.patch [deleted file]
dev-lang/R/files/R-2.13.1-zlib_header_fix.patch [deleted file]
dev-lang/R/files/R-3.0.0-rmath-shared.patch [deleted file]
dev-lang/R/files/R-3.3.2-zlib-1.2.10-backport.patch [deleted file]

diff --git a/dev-lang/R/files/R-2.11.1-parallel.patch b/dev-lang/R/files/R-2.11.1-parallel.patch
deleted file mode 100644 (file)
index c713d33..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-Fix ocasional failure with parallel install
-Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=322965
-R bug: https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14505
-
-Patch by Sebastien Fabbro
-
---- src/include/Makefile.in.orig       2010-06-15 18:18:54.000000000 +0000
-+++ src/include/Makefile.in    2010-06-15 18:19:48.000000000 +0000
-@@ -81,7 +81,7 @@
- Rmath.h0: $(srcdir)/Rmath.h0.in $(top_builddir)/config.status
-       @cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@
--install: installdirs install-intl-@USE_INCLUDED_LIBINTL@
-+install: $(OBJ_HEADERS) installdirs install-intl-@USE_INCLUDED_LIBINTL@
-       @for d in $(SUBDIRS); do \
-         (cd $${d} && $(MAKE) $@) || exit 1; \
-       done
diff --git a/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch b/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch
deleted file mode 100644 (file)
index 136acb2..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-Update for zlib header changes for zlib > 1.2.5
-
-Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=383431
-R bug: https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14951
-
-Patch by Michael Schreckenbauer
-
---- src/main/unzip.h.orig      2011-09-24 19:35:53.000000000 -0700
-+++ src/main/unzip.h   2011-09-24 19:37:06.000000000 -0700
-@@ -58,6 +58,10 @@
- #define ZLIB_FILEFUNC_SEEK_END (2)
- #define ZLIB_FILEFUNC_SEEK_SET (0)
-+#ifndef OF
-+#define OF(x) x
-+#endif
-+
- #define ZLIB_FILEFUNC_MODE_READ      (1)
- #define ZLIB_FILEFUNC_MODE_WRITE     (2)
- #define ZLIB_FILEFUNC_MODE_READWRITEFILTER (3)
diff --git a/dev-lang/R/files/R-3.0.0-rmath-shared.patch b/dev-lang/R/files/R-3.0.0-rmath-shared.patch
deleted file mode 100644 (file)
index f53fb79..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-Link with libm to fix unresolved symbols when linked with as-needed
-and add a soname to the standalone math library
-R bug: https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14953
-
-Patch by Sebastien Fabbro
-Adapted to R-3.0.0 by Denis Dupeyron
-
---- src/nmath/standalone/Makefile.in.orig      2013-04-04 14:39:15.777544946 -0600
-+++ src/nmath/standalone/Makefile.in   2013-04-04 14:40:51.256153179 -0600
-@@ -64,7 +64,8 @@
- Rexeclibdir_LTLIBRARIES = $(libRmath_la)
- libRmath_la_SOURCES = $(SOURCES)
- libRmath_la_OBJECTS = $(OBJECTS:.o=.lo)
--libRmath_la_LDFLAGS =
-+libRmath_la_LDFLAGS = -Wl,-soname=libRmath.so
-+libRmath_la_LIBADD = $(LIBM)
- CLEANFILES = Makedeps *.d *.o *.lo test $(SOURCES)
- DISTCLEANFILES = Makefile $(Rexeclibdir_LIBRARIES) $(Rexeclibdir_LTLIBRARIES)
-@@ -117,7 +118,7 @@
- ## under peculiar circumstances, $(LIBM) here helps.
- $(libRmath_la): $(libRmath_la_OBJECTS)
--      $(DYLIB_LINK) -o $@ $(libRmath_la_LDFLAGS) $(libRmath_la_OBJECTS) $(LIBM)
-+      $(DYLIB_LINK) $(libRmath_la_LDFLAGS) $(libRmath_la_OBJECTS) $(libRmath_la_LIBADD) -o $@
- test: $(srcdir)/test.c
-       $(CC) -o $@ $(ALL_CPPFLAGS) $(ALL_CFLAGS) $(srcdir)/test.c \
diff --git a/dev-lang/R/files/R-3.3.2-zlib-1.2.10-backport.patch b/dev-lang/R/files/R-3.3.2-zlib-1.2.10-backport.patch
deleted file mode 100644 (file)
index 2cfb30d..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: R.m4
-===================================================================
---- m4/R.m4    (revision 71152)
-+++ m4/R.m4    (revision 71889)
-@@ -3105,10 +3105,11 @@
- #include <string.h>
- #include <zlib.h>
- int main() {
--#ifdef ZLIB_VERSION
--/* Work around Debian bug: it uses 1.2.3.4 even though there was no such
--   version on the master site zlib.net */
--  exit(strncmp(ZLIB_VERSION, "1.2.5", 5) < 0);
-+#ifdef ZLIB_VERNUM
-+  if (ZLIB_VERNUM < 0x1250) {
-+    exit(1);
-+  }
-+  exit(0);
- #else
-   exit(1);
- #endif