media-gfx/iscan: fix building with boost 1.73
authorMarcin Deranek <marcin.deranek@booking.com>
Sun, 10 May 2020 11:52:32 +0000 (13:52 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 10 May 2020 12:05:52 +0000 (14:05 +0200)
Closes: https://bugs.gentoo.org/721696
Signed-off-by: Marcin Deranek <marcin.deranek@slonko.net>
Closes: https://github.com/gentoo/gentoo/pull/15737
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/iscan/files/iscan-3.62.0-boost-1.73.patch [new file with mode: 0644]
media-gfx/iscan/iscan-3.62.0.ebuild

diff --git a/media-gfx/iscan/files/iscan-3.62.0-boost-1.73.patch b/media-gfx/iscan/files/iscan-3.62.0-boost-1.73.patch
new file mode 100644 (file)
index 0000000..d55a464
--- /dev/null
@@ -0,0 +1,33 @@
+diff -urN a/drivers/esci/verify.cpp b/drivers/esci/verify.cpp
+--- a/drivers/esci/verify.cpp  2019-11-18 04:08:45.000000000 +0200
++++ b/drivers/esci/verify.cpp  2020-05-09 20:22:00.899968638 +0300
+@@ -58,6 +58,7 @@
+ using namespace utsushi;
+ using namespace _drv_::esci;
++using namespace boost::placeholders;
+ using std::basic_string;
+ using std::ios_base;
+diff -urN a/lib/monitor.cpp b/lib/monitor.cpp
+--- a/lib/monitor.cpp  2019-11-18 04:08:08.000000000 +0200
++++ b/lib/monitor.cpp  2020-05-09 20:22:26.392174029 +0300
+@@ -49,6 +49,7 @@
+ namespace utsushi {
+ using boost::filesystem::exists;
++using namespace boost::placeholders;
+ class monitor::impl
+ {
+diff -urN a/sane/handle.cpp b/sane/handle.cpp
+--- a/sane/handle.cpp  2019-11-18 04:08:08.000000000 +0200
++++ b/sane/handle.cpp  2020-05-09 20:21:49.559223712 +0300
+@@ -65,6 +65,7 @@
+ using utsushi::_flt_::deskew;
+ using utsushi::_flt_::autocrop;
+ using utsushi::_flt_::pnm;
++using namespace boost::placeholders;
+ namespace sane {
index f5957958df9abea68ac8f7af5850a5656f22e8d1..f01a67d24171742d74a7385cdd725dfd271cafa6 100644 (file)
@@ -33,6 +33,7 @@ PATCHES=(
        "${FILESDIR}"/${PN}-3.61.0-ijg-libjpeg.patch
        "${FILESDIR}"/${PN}-3.61.0-imagemagick-7.patch
        "${FILESDIR}"/${PN}-3.62.0-gcc-10.patch
+       "${FILESDIR}"/${PN}-3.62.0-boost-1.73.patch
 )
 
 src_prepare() {