virtual/python-funcsigs: require correct USE flags of python/funcsigs
authorAlexey Sokolov <sokolov@google.com>
Mon, 10 Dec 2018 08:43:26 +0000 (08:43 +0000)
committerMike Gilbert <floppym@gentoo.org>
Sun, 30 Dec 2018 20:31:45 +0000 (15:31 -0500)
Closes: https://bugs.gentoo.org/672890
Closes: https://github.com/gentoo/gentoo/pull/10603
Signed-off-by: Alexey Sokolov <sokolov@google.com>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
virtual/python-funcsigs/python-funcsigs-2.ebuild [new file with mode: 0644]

diff --git a/virtual/python-funcsigs/python-funcsigs-2.ebuild b/virtual/python-funcsigs/python-funcsigs-2.ebuild
new file mode 100644 (file)
index 0000000..a5104ac
--- /dev/null
@@ -0,0 +1,17 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A Virtual for Python function signatures from PEP362 (py3.6 variant)"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+       ${PYTHON_DEPS}
+       $(python_gen_cond_dep '>=dev-python/funcsigs-1[${PYTHON_USEDEP}]' python2_7 python3_{3,4,5} pypy{,3} )"