sys-apps/fwupd: Fixed build with USE="minimal"
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 16 Oct 2019 13:08:53 +0000 (15:08 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 16 Oct 2019 13:09:24 +0000 (15:09 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/fwupd/fwupd-1.3.2.ebuild

index a1ab427a019844cc7a6afb180a1cfabe722e5839..b8f2e661981931c93019ceef3be89ee811e58d86 100644 (file)
@@ -133,15 +133,17 @@ src_configure() {
 src_install() {
        meson_src_install
 
-       sed "s@%SEAT_MANAGER%@$(usex elogind elogind consolekit)@" \
-               "${FILESDIR}"/${PN}-r1 \
-               > "${T}"/${PN} || die
-       doinitd "${T}"/${PN}
+       if ! use minimal ; then
+               sed "s@%SEAT_MANAGER%@$(usex elogind elogind consolekit)@" \
+                       "${FILESDIR}"/${PN}-r1 \
+                       > "${T}"/${PN} || die
+               doinitd "${T}"/${PN}
 
-       if ! use systemd ; then
-               # Don't timeout when fwupd is running (#673140)
-               sed '/^IdleTimeout=/s@=[[:digit:]]\+@=0@' \
-                       -i "${ED}"/etc/${PN}/daemon.conf || die
+               if ! use systemd ; then
+                       # Don't timeout when fwupd is running (#673140)
+                       sed '/^IdleTimeout=/s@=[[:digit:]]\+@=0@' \
+                               -i "${ED}"/etc/${PN}/daemon.conf || die
+               fi
        fi
 }