app-admin/salt-2019.2.4: Version bump
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 29 Apr 2020 20:30:14 +0000 (13:30 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 29 Apr 2020 20:30:23 +0000 (13:30 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
app-admin/salt/Manifest
app-admin/salt/salt-2019.2.4.ebuild [moved from app-admin/salt/salt-2019.2.3.ebuild with 90% similarity]

index bf06df6f8c2bb996c5c49e96c802b3d2666cd682..f5cc57ada94bb783b2be0482e97f510cc25d1b1a 100644 (file)
@@ -1,2 +1,2 @@
 DIST salt-2018.3.4.tar.gz 14404085 BLAKE2B 932b30b1ba60aefd3a6874a8ebe4cb6c469d82e31f6acdbe8a5641d09e3316796b5403ef803a355cec6255c1aede8bac3b66af179bd1bbaa5418c7076229cef9 SHA512 f17e06fdbf4741f231d9e769be57de4f6079e9283881b4bafa0d23928d7626a1f9c02b9f49c654b29c3e6ee8ed3d3ddf42c21baecef158ad63a97dc87895b21b
-DIST salt-2019.2.3.tar.gz 14572686 BLAKE2B 770b815f43ca8651408c1c057377b02c8037e673584c719e0a9b5c56c13c8db2db0e2c8641a17323f2b890d4a69d1508b0090624c7067869d9fa84303c2f8585 SHA512 cd694ca19696a84e3370e39c61da180e508592253713d99dd6dd5342b57c2814fee22e46bade30d7604f5730d9e1a736e59c3a512161f744d3f097f74a2836c5
+DIST salt-2019.2.4.tar.gz 14572556 BLAKE2B a1057baa5ab6c0a07f34ce658a1d5bc644f968600663d28d084eb712b55faaee93b8410d81c4b5324944e6e1f2067ffb102200088832e1b0076fed78c8542ae6 SHA512 9e621cbd78ead1060a2b0c07e7ef02e8c4590360a95c51ac29fa8c1add34f617e4407dd28b67cae3b0fd68b333782185edcf1159edd2db08e8b4e79b6b07a63f
similarity index 90%
rename from app-admin/salt/salt-2019.2.3.ebuild
rename to app-admin/salt/salt-2019.2.4.ebuild
index c6961f4ebef6fafdd8a2775ee51ed7fb98d75967..37adb4ff1a42107cc99fbb348b08ebd471b163aa 100644 (file)
@@ -3,8 +3,8 @@
 
 EAPI=7
 PYTHON_COMPAT=( python3_6 )
-
-inherit eutils systemd distutils-r1
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit systemd distutils-r1
 
 DESCRIPTION="Salt is a remote execution and configuration manager"
 HOMEPAGE="https://www.saltstack.com/resources/community/
@@ -23,13 +23,15 @@ fi
 
 LICENSE="Apache-2.0"
 SLOT="0"
-IUSE="cherrypy ldap libcloud libvirt gnupg keyring mako mongodb neutron nova"
-IUSE+=" openssl portage profile redis selinux test raet +zeromq vim-syntax"
+IUSE="cherrypy ldap libcloud libvirt gnupg keyring mako mongodb neutron nova
+       openssl portage profile redis selinux test raet +zeromq vim-syntax"
 
-RDEPEND="sys-apps/pciutils
+RDEPEND="
+       sys-apps/pciutils
        dev-python/jinja[${PYTHON_USEDEP}]
        dev-python/libnacl[${PYTHON_USEDEP}]
        >=dev-python/msgpack-0.3[${PYTHON_USEDEP}]
+       <dev-python/msgpack-1.0[${PYTHON_USEDEP}]
        dev-python/pyyaml[${PYTHON_USEDEP}]
        dev-python/markupsafe[${PYTHON_USEDEP}]
        >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
@@ -64,22 +66,22 @@ RDEPEND="sys-apps/pciutils
        gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
        profile? ( dev-python/yappi[${PYTHON_USEDEP}] )
        vim-syntax? ( app-vim/salt-vim )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
-               >=dev-python/pytest-salt-2018.12.8[${PYTHON_USEDEP}]
+               >=dev-python/boto-2.32.1[${PYTHON_USEDEP}]
                >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+               >=dev-python/libcloud-0.14.0[${PYTHON_USEDEP}]
+               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/moto-0.3.6[${PYTHON_USEDEP}]
+               dev-python/pip[${PYTHON_USEDEP}]
                dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+               >=dev-python/pytest-salt-2018.12.8[${PYTHON_USEDEP}]
                dev-python/psutil[${PYTHON_USEDEP}]
                dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-catchlog[${PYTHON_USEDEP}]
-               dev-python/pip[${PYTHON_USEDEP}]
+               >=dev-python/SaltTesting-2016.5.11[${PYTHON_USEDEP}]
                dev-python/virtualenv[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/boto-2.32.1[${PYTHON_USEDEP}]
                !x86? ( >=dev-python/boto3-1.2.1[${PYTHON_USEDEP}] )
-               >=dev-python/moto-0.3.6[${PYTHON_USEDEP}]
-               >=dev-python/SaltTesting-2016.5.11[${PYTHON_USEDEP}]
-               >=dev-python/libcloud-0.14.0[${PYTHON_USEDEP}]
                ${RDEPEND}
        )"
 
@@ -131,20 +133,17 @@ python_test() {
        mkdir "${BUILD_DIR}"/../{templates,conf/cloud.{providers,profiles,maps}.d} || die
 
        (
-               cleanup() {
-                       rm -f "${tempdir}"
-                       rmdir "${BUILD_DIR}"/../{templates,conf/cloud.{providers,profiles,maps}.d} || die
-               }
+               cleanup() { rm -f "${tempdir}" || die; }
 
                trap cleanup EXIT
 
                addwrite "${tempdir}"
-               ln -s "$(realpath --relative-to=/tmp "${T}/$(basename "${tempdir}")")" "${tempdir}"
+               ln -s "$(realpath --relative-to=/tmp "${T}/$(basename "${tempdir}")")" "${tempdir}" || die
 
                USE_SETUPTOOLS=1 SHELL="/bin/bash" \
                        TMPDIR="${tempdir}" \
                        ${EPYTHON} tests/runtests.py \
-                       --unit-tests --no-report --verbose
-
-       ) || die "testing failed"
+                       --unit-tests --no-report --verbose \
+                       || die "testing failed with ${EPYTHON}"
+       )
 }