Fix compilation issue when automake-1.10 is around. Fixes bug #161093.
authorPeter Johanson <latexer@gentoo.org>
Thu, 18 Jan 2007 08:22:41 +0000 (08:22 +0000)
committerPeter Johanson <latexer@gentoo.org>
Thu, 18 Jan 2007 08:22:41 +0000 (08:22 +0000)
eclass/gtk-sharp-component.eclass

index 42416015c9930ef20d84a54ed7526607534ad15f..901ce399979452cb3ed6f43fde6df59da934254c 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gtk-sharp-component.eclass,v 1.27 2006/09/07 06:46:57 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gtk-sharp-component.eclass,v 1.28 2007/01/18 08:22:41 latexer Exp $
 
 # Author : Peter Johanson <latexer@gentoo.org>
 # Based off of original work in gst-plugins.eclass by <foser@gentoo.org>
@@ -138,6 +138,13 @@ gtk-sharp-component_src_unpack() {
                        ${S}/gconf/GConf/*.pc.in || die
        fi
 
+       if [ -f "${S}/sample/gconf/Makefile.am" ]
+       then
+               # Fix install data hook (bug #161093)
+               sed -i -e 's/^install-hook/install-data-hook/' \
+                       ${S}/sample/gconf/Makefile.am || die "sed failed"
+       fi
+
        # disable building of samples (#16015)
        sed -i -e "s:sample::" ${S}/Makefile.am || die