Version bump (thanks to Conrad Kostecki <ConiKost at gmx.de> in #114232).
authorChristian Heim <phreak@gentoo.org>
Sun, 21 Jan 2007 15:31:05 +0000 (15:31 +0000)
committerChristian Heim <phreak@gentoo.org>
Sun, 21 Jan 2007 15:31:05 +0000 (15:31 +0000)
Package-Manager: portage-2.1.2-r1

dev-libs/apr-util/ChangeLog
dev-libs/apr-util/apr-util-1.2.8.ebuild [new file with mode: 0644]
dev-libs/apr-util/files/digest-apr-util-1.2.8 [new file with mode: 0644]
dev-libs/apr/ChangeLog
dev-libs/apr/apr-1.2.8.ebuild [new file with mode: 0644]
dev-libs/apr/files/digest-apr-1.2.8 [new file with mode: 0644]

index 73b4c50ab80e4c6ae9c19c834a279e339e352f9b..9aec7a3db24c80aade73e8cb19c91a25bae4706c 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-libs/apr-util
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.66 2006/10/18 16:06:14 uberlord Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.67 2007/01/21 15:31:05 phreak Exp $
+
+*apr-util-1.2.8 (21 Jan 2007)
+
+  21 Jan 2007; Christian Heim <phreak@gentoo.org> +apr-util-1.2.8.ebuild:
+  Version bump (thanks to Conrad Kostecki <ConiKost at gmx.de> in #114232).
 
   18 Oct 2006; Roy Marples <uberlord@gentoo.org> apr-util-0.9.12.ebuild:
   Added ~sparc-fbsd keyword.
diff --git a/dev-libs/apr-util/apr-util-1.2.8.ebuild b/dev-libs/apr-util/apr-util-1.2.8.ebuild
new file mode 100644 (file)
index 0000000..2c636e7
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.2.8.ebuild,v 1.1 2007/01/21 15:31:05 phreak Exp $
+
+inherit eutils flag-o-matic libtool db-use
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="berkdb gdbm ldap postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND="dev-libs/expat
+       ~dev-libs/apr-${PV}
+       berkdb? ( =sys-libs/db-4* )
+       gdbm? ( sys-libs/gdbm )
+       ldap? ( =net-nds/openldap-2* )
+       postgres? ( dev-db/postgresql )
+       sqlite? ( =dev-db/sqlite-2* )
+       sqlite3? ( =dev-db/sqlite-3* )"
+
+# NOTE: This package in theory can support mysql,
+# but in reality the build system is broken for it....
+
+src_compile() {
+       local myconf=""
+
+       elibtoolize || die "elibtoolize failed"
+
+       use ldap && myconf="${myconf} --with-ldap"
+
+       if use berkdb; then
+               dbver="$(db_findver sys-libs/db)" || die "Unable to find db version"
+               dbver="$(db_ver_to_slot "$dbver")"
+               dbver="${dbver/\./}"
+               myconf="${myconf} --with-dbm=db${dbver}
+               --with-berkeley-db=$(db_includedir):/usr/$(get_libdir)"
+       else
+               myconf="${myconf} --without-berkeley-db"
+       fi
+
+       econf --datadir=/usr/share/apr-util-1 \
+               --with-apr=/usr \
+               --with-expat=/usr \
+               $(use_with gdbm) \
+               $(use_with postgres pgsql) \
+               $(use_with sqlite sqlite2) \
+               $(use_with sqlite3) \
+               ${myconf} || die "econf failed!"
+
+       emake || die "emake failed!"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "make install failed"
+
+       dodoc CHANGES NOTICE
+
+       # This file is only used on AIX systems, which gentoo is not,
+       # and causes collisions between the SLOTs, so kill it
+       rm "${D}"/usr/$(get_libdir)/aprutil.exp
+}
\ No newline at end of file
diff --git a/dev-libs/apr-util/files/digest-apr-util-1.2.8 b/dev-libs/apr-util/files/digest-apr-util-1.2.8
new file mode 100644 (file)
index 0000000..bf335ad
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 a2e2e54d65e9eae961f7171335cf2550 apr-util-1.2.8.tar.gz 646379
+RMD160 00b10ef0aab26f3ea5d374e2400c1dba566a9020 apr-util-1.2.8.tar.gz 646379
+SHA256 6527cb0b3dd619acfca668412e84e52860dfd862054246ca903822d5ea824de6 apr-util-1.2.8.tar.gz 646379
index 76babf97edde66146747c200dad904408173d4cf..e4d5ca202e60b42439622e817bd6e1b2d5909d1d 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-libs/apr
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.74 2007/01/08 23:35:43 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.75 2007/01/21 15:27:39 phreak Exp $
+
+*apr-1.2.8 (21 Jan 2007)
+
+  21 Jan 2007; Christian Heim <phreak@gentoo.org> +apr-1.2.8.ebuild:
+  Version bump (thanks to Conrad Kostecki <ConiKost at gmx.de> in #114232).
 
   08 Jan 2007; Christian Heim <phreak@gentoo.org> apr-1.2.7-r1.ebuild,
   apr-1.2.7-r2.ebuild, apr-1.2.7-r3.ebuild:
diff --git a/dev-libs/apr/apr-1.2.8.ebuild b/dev-libs/apr/apr-1.2.8.ebuild
new file mode 100644 (file)
index 0000000..f98e7db
--- /dev/null
@@ -0,0 +1,89 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.2.8.ebuild,v 1.1 2007/01/21 15:27:39 phreak Exp $
+
+WANT_AUTOCONF="2.5"
+WANT_AUTOMAKE="1.1"
+
+inherit autotools
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ipv6 urandom debug"
+RESTRICT="test"
+
+DEPEND=""
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       # for some reason not all the .m4 files that are referenced in 
+       # configure.in exist, so we remove all references and include every
+       # .m4 file in build using aclocal via eautoreconf
+       # See bug 135463
+       sed -i -e '/sinclude/d' configure.in
+       AT_M4DIR="build" eautoreconf
+
+       epatch "${FILESDIR}"/config.layout.patch
+
+}
+
+src_compile() {
+       # For now we always enable ipv6. Testing has shown that is still works
+       # correctly in ipv4 systems, and currently, the ipv4-only support
+       # is broken in apr. (ipv6 is enabled by default)
+       #myconf="${myconf} $(use_enable ipv6)"
+
+       if use urandom; then
+               myconf="${myconf} --with-devrandom=/dev/urandom"
+       else
+               myconf="${myconf} --with-devrandom=/dev/random"
+       fi
+
+       use debug && myconf="${myconf} --enable-maintainer-mode"
+
+       # We pre-load the cache with the correct answer!  This avoids
+       # it violating the sandbox.  This may have to be changed for
+       # non-Linux systems or if sem_open changes on Linux.  This
+       # hack is built around documentation in /usr/include/semaphore.h
+       # and the glibc (pthread) source
+       # See bugs 24215 and 133573
+       echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> "${S}"/config.cache
+
+       econf --enable-layout=gentoo \
+                --enable-threads \
+                --enable-nonportable-atomics \
+                ${myconf} || die "econf failed!"
+
+       # Make sure we use the system libtool
+       sed -i 's,$(apr_builddir)/libtool,/usr/bin/libtool,' "${S}"/build/apr_rules.mk
+       sed -i 's,${installbuilddir}/libtool,/usr/bin/libtool,' "${S}"/apr-1-config
+       rm -f "${S}"/libtool
+
+       emake || die "Make failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "make install failed"
+
+       # This file is only used on AIX systems, which gentoo is not,
+       # and causes collisions between the SLOTs, so kill it
+       rm "${D}"/usr/$(get_libdir)/apr.exp
+
+       dodoc CHANGES NOTICE LICENSE
+}
+
+pkg_postinst() {
+       ewarn "We are now using the system's libtool rather then bundling"
+       ewarn "our own. You will need to rebuild Apache and possibly other"
+       ewarn "software if you get a message similiar to the following:"
+       ewarn
+       ewarn "   /usr/share/apr-1/build-1/libtool: No such file or directory"
+       ewarn
+}
\ No newline at end of file
diff --git a/dev-libs/apr/files/digest-apr-1.2.8 b/dev-libs/apr/files/digest-apr-1.2.8
new file mode 100644 (file)
index 0000000..7e31fb5
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 814f19528d9cfc79aef188dd752e04d8 apr-1.2.8.tar.gz 1107189
+RMD160 299e1ddb1f7c9b0169a410e120c30abea38557c5 apr-1.2.8.tar.gz 1107189
+SHA256 96e31f0ea2e028f372d5fdbbd4f88f31d59e14eda85cd12153183759f8e221c7 apr-1.2.8.tar.gz 1107189