sys-apps/pkgcore: version bump to 0.10.0
authorTim Harder <radhermit@gentoo.org>
Fri, 23 Aug 2019 09:26:57 +0000 (03:26 -0600)
committerTim Harder <radhermit@gentoo.org>
Fri, 23 Aug 2019 09:56:59 +0000 (03:56 -0600)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
sys-apps/pkgcore/Manifest
sys-apps/pkgcore/pkgcore-0.10.0.ebuild [new file with mode: 0644]
sys-apps/pkgcore/pkgcore-9999.ebuild

index 6b1bb821c57c0cd0b95867b854faf821f70fa546..49ae3a10081c40d308ee521133cb72f75cd3538e 100644 (file)
@@ -1 +1,2 @@
+DIST pkgcore-0.10.0.tar.gz 644294 BLAKE2B aec57ff84d82bb678b6a4d8f22a3787e3155479c71892203fc886c14ead47d56880178b0dd456430b9d9f62f51ab18b8d43a56d8989a31d8c7839cc981c1d9cc SHA512 baa4d28c9abb2e79b69d7bdb047ffeb6330c9a46318073afffbf989e8e34a097ba10264473e61def4490912d041592c74925ab9718e60bc009307eeafc04a70b
 DIST pkgcore-0.9.7.tar.gz 592202 BLAKE2B fa16380e89ad2fb2a05d8f08387c3cfa2203b4e6faad3fc4758d572eb08d6c64f781eef8c2d56151f1facec3a202325d4c4a271a1a3ced88df7371f2af75dbf3 SHA512 cb996fd35a8e4e73acfacf1942d498932ec092a282397bd41df72eea26b6d08c15e01b96ece8ebb6876e84281d85d4f8ef81e1f2ef107adff1b984ee592d6a6f
diff --git a/sys-apps/pkgcore/pkgcore-0.10.0.ebuild b/sys-apps/pkgcore/pkgcore-0.10.0.ebuild
new file mode 100644 (file)
index 0000000..9c3d2f6
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+       inherit git-r3
+else
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+if [[ ${PV} == *9999 ]]; then
+       RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+       RDEPEND+=" >=dev-python/snakeoil-0.8.1[${PYTHON_USEDEP}]"
+fi
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+       local esetup_args=( $(usex doc "--enable-html-docs" "") )
+       # only build man pages for live ebuilds if doc USE flag is enabled
+       [[ ${PV} == *9999 ]] && esetup_args+=( $(usex doc "--enable-man-pages" "") )
+       esetup.py build "${esetup_args[@]}"
+}
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       esetup.py install_docs \
+               --docdir="${ED%/}/usr/share/doc/${PF}" \
+               --mandir="${ED%/}/usr/share/man"
+       distutils-r1_python_install_all
+}
index 308d58adcb671d0b6227271d0cafc73425f46f12..9c3d2f6fb0679f37dcf8fc77e0f95b429cb6caeb 100644 (file)
@@ -17,19 +17,19 @@ fi
 DESCRIPTION="a framework for package management"
 HOMEPAGE="https://github.com/pkgcore/pkgcore"
 
-LICENSE="|| ( BSD GPL-2 )"
+LICENSE="BSD"
 SLOT="0"
 IUSE="doc test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
 if [[ ${PV} == *9999 ]]; then
        RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
 else
-       RDEPEND+=" >=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]"
+       RDEPEND+=" >=dev-python/snakeoil-0.8.1[${PYTHON_USEDEP}]"
 fi
 DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/pyparsing[${PYTHON_USEDEP}]
        doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? ( dev-python/pytest[${PYTHON_USEDEP}] )
 "